<textarea rows=1> shows 3 rows

VERIFIED DUPLICATE of bug 33654

Status

()

Core
Layout: Form Controls
P2
normal
VERIFIED DUPLICATE of bug 33654
16 years ago
15 years ago

People

(Reporter: A.J. Kruit, Assigned: rods (gone))

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
If in the <Text Area rows=1>  Then mozilla let me show 3 rows. It must be one.
I Find it out in are our intranet work.

Please repair

Thanks

A.J. Kruit

Comment 1

16 years ago
confirming as bug...
to test use following code:

<html><head></head><body><form action="">
<textarea rows="1">onerow</textarea><br><br>
<textarea rows="3">threerow</textarea><br><br>
<textarea rows="5">fiverow</textarea><br><br>
</form></body></html>

funny thing... mozilla showes 3 rows at the rows=1 statement
shows 4 rows on the rows=3 statement
and 6 rows on the rows=5 statement :)

marking as new
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 62719 [details]
The testcase
(Assignee)

Comment 3

16 years ago
The real bug is that the horizontal scrollbar should always be displayed and is
not. If you add more text so the horizontal scrollbars appears. All the tests
are correct except for rows=1, which shows two rods for some reason.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2
(Assignee)

Updated

16 years ago
Priority: -- → P2
Target Milestone: mozilla1.2 → Future

Updated

16 years ago
QA Contact: madhur → tpreston

Updated

16 years ago
Summary: Text Area → <textarea rows=1> shows 3 rows

Comment 4

16 years ago
The reason that rows="1" results in a height of 3 rows is because there are two
points where the textare height is increased beyond a single line:

http://lxr.mozilla.org/mozilla/source/layout/html/forms/src/nsGfxTextControlFrame2.cpp#1745

In this case, we seem to be explicitly growing an extra row when rows="1" (is
there any good reason for this?)

http://lxr.mozilla.org/mozilla/source/layout/html/forms/src/nsGfxTextControlFrame2.cpp#1611

Here we are adding the height of the horizontal scrollbar, regardless of whether
one is needed.

Comment 5

15 years ago
I´ve experienced the same problem,
but this bug seems to be a duplicate of bug 33654
Depends on: 33654

Comment 6

15 years ago
Dupe, they even have identical testcases.

*** This bug has been marked as a duplicate of 33654 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
v.
Status: RESOLVED → VERIFIED

Updated

15 years ago
No longer depends on: 33654
You need to log in before you can comment on or make changes to this bug.