Going back shows an out of date page.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: jya, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dom-triaged)

(Reporter)

Description

4 years ago
Not sure which category this bug belongs to.

When using a page like:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound

that site will update via AJAX and content will change over time.
If you click on a link, you go to the link as expected.

Pressing Back button takes you back to the previous page (https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound) however the content displayed is of the page as it was first loaded. None of the updates the page received over time will show.

You must press refresh to get the newer, updated content.
You would expect when pressing back, that it would redisplay the page as it was prior to when clicking on the link.

STR:
Go to https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound
leave the page idle for a while until some changes are added.
Click on a bug number, press back. The old original content is displayed.

Updated

3 years ago
Component: General → Document Navigation
Product: Firefox → Core
I don't know what the behaviour should be here nor if docshell is controlling this. smaug?
Flags: needinfo?(bugs)
Whiteboard: dom-triaged
I can't see this happening and this sounds like a bug in the page.
jya, do you still see this?
Flags: needinfo?(bugs) → needinfo?(jyavenard)
(Reporter)

Comment 3

3 years ago
i can't reproduce it in Developer Edition.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jyavenard)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.