Closed Bug 1167859 Opened 7 years ago Closed 7 years ago

Can't hide soft keys while in fullscreen

Categories

(Firefox for Android Graveyard :: General, defect)

38 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1031519

People

(Reporter: u529383, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36

Steps to reproduce:

Note: I can't select the latest Firefox android version 38 because this website says that it doesn't exist.


Enter fullscreen from, for example, an html5 player like the one in this website: http://www.videojs.com/



Actual results:

Soft keys never hide resulting in an horrendous viewing experience as the attached screenshots show, keeping the video smaller than the size the screen can actually provide and a permanent distracting element always visible next to the video.


Expected results:

Soft keys should hide after X time after entering fullscreen and/or after user taps the video (or at the very least be able to be hidden via javascript/add-on method), double-tap on the screen should exit fullscreen if required otherwise the video viewing experience in Firefox Android is absolutely discouraging,

The appropriate fullscreen behavior that is present in the YouTube app could be used as a working example of what the Firefox for android fullscreen should do
Version: unspecified → Firefox 38
\
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1031519
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.