Copy-pasted text with moz-txt-link-abbreviated link omits preceding space upon send, breaks mailinglist-confirmation

NEW
Unassigned

Status

Thunderbird
Message Compose Window
2 years ago
2 years ago

People

(Reporter: Elbart, Unassigned)

Tracking

({dataloss})

x86_64
Unspecified
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I got a plain-text mail (no html-section) from a mailing-list-bot to confirm a subscription, with the line like 

auth deadbeef subscribe list-name mail@address.com

Checking the clipboard, in the text/html-version of the copied text the mail-address was linkified with the class "moz-txt-link-abbreviated" within a <pre wrap=""> .

Copying this text into a new mail and sending it as plain-text back to the mailinglist-bot turned the text into

auth deadbeef subscribe linux-mediamail@address.com

with which the confirmation didn't succeed.

Only after pasting the copied text into an editor, thus stripping it of all formating, and then copy-pasting that text into a new mail, the confirmation did work.

Comment 1

2 years ago
Note that there is a duplicate report:

1160880 – Selecting text & replying in plain text eats spaces in some situations
https://bugzilla.mozilla.org/show_bug.cgi?id=1160880

Comment 2

2 years ago
DUP!

@reporter: What is your TB Version?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1160880

Comment 3

2 years ago
I wanted to see whether the bug was correctly made a duplicate of bug 1160880. 
I can reproduce it in TB 3.1 (yes, three point one):

1. I used the message from bug 1160880 and selected the |subscribe postfix-users de.techno@gmail.com|
2. "Check the clipboard" - I wouldn't know how.
3. "Copy the text into a new e-mail": Done that and sent to myself.
4. Result: |subscribe postfix-usersde.techno@gmail.com| got sent and received.

Note: When looking at the draft before sending it, I saw:
<pre wrap="">subscribe postfix-users <a class="moz-txt-link-abbreviated" href="mailto:de.techno@gmail.com">de.techno@gmail.com</a></pre>

I am tipping that the problem happens when the HTML is converted to plain text.
This can happen when the message is being sent, as in this bug, or when the message is answered, as in bug 1160880.

So I am tipping that this is indeed a duplicate of the other bug, although the STR are very different.
Version: Trunk → 3.1

Comment 4

2 years ago
Actually, I'm not comfortable of making this a duplicate, since I will tag this "dataloss".
Clearly the e-mail sent is not what the user intended.
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: dataloss
Resolution: DUPLICATE → ---

Updated

2 years ago
Status: REOPENED → NEW

Updated

2 years ago
See Also: → bug 1160880

Updated

2 years ago
Summary: Copy-pasted text with moz-txt-link-abbreviated link omits preceding space, breaks mailinglist-confirmation → Copy-pasted text with moz-txt-link-abbreviated link omits preceding space upon send, breaks mailinglist-confirmation
(In reply to Elbart from comment #0)

To bug opener:
Comment #0 is phenomeno in which Thunderbird version?
Note: Version: field of initil trunk was changed to 3.1 by mozilla@jorgk.com on 2015-08-13. (See History of this bug)
You need to log in before you can comment on or make changes to this bug.