[Stingray][Dashboard] Support key navigation betwen dashboard and inside widget.

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rexboy, Assigned: rexboy)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ft:conndevices])

Attachments

(2 attachments)

When expanding the widget, we have to move focus into widget.
When shrinking the widget, we have to move focus back to dashboard.

Specifically, Once user presses right, the right widget should got the focus; and lose it when user press left to go back.

We may need to use onbeforekeydown to achieve this.
Assignee: nobody → rexboy
Created attachment 8610526 [details] [review]
[gaia] rexboy7:1168035-focus-on-widget > mozilla-b2g:master
Created attachment 8610527 [details] [review]
patch

John may you review this patch? You can send it to Yifan if you feel necessary. Thanks!
Attachment #8610527 - Flags: review?(im)
Comment on attachment 8610527 [details] [review]
patch

Looks good to me. I had left some issues at PR.

BTW, it would be nice to have the following two things:
1. add focus handling at weather-widget to move between those two timezone.
2. add integration test to test the focus change.

Once we have focus handling at weather-widget, we can have a test to send left, right key events to the widget iframe and to check if the focus is changed.
Attachment #8610527 - Flags: review?(im) → review+
Please rebase to master to have gij-tv displayed on your tree herder tests.
Since weather-widget doesn't have any focusable elements by design, if we adds focus handling on it, they would be purely developing/demo purpose. So I tend to do it later.
Comment on attachment 8610527 [details] [review]
patch

I have some changes specified for mozbeforekey/mozafterkey events. The changes are not very major but I think they need a second review. I put my modifications on the second commit.
John would you mind reviewing them again? Thank you!
Attachment #8610527 - Flags: review+ → review?(im)
Comment on attachment 8610527 [details] [review]
patch

looks good to me.
Attachment #8610527 - Flags: review?(im) → review+
Thank you John!

master
https://github.com/mozilla-b2g/gaia/commit/7b2b3fedbc6304488dca05e617e99e758a66443b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.