redirects appear to cause crashes (TB882536W, TB843261Z)

RESOLVED DUPLICATE of bug 115672

Status

()

Core
Networking: Cache
--
critical
RESOLVED DUPLICATE of bug 115672
16 years ago
16 years ago

People

(Reporter: Dave Goldblatt, Assigned: gordon)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.7+)
Gecko/20011224
BuildID:    2001122408

On several sites the nightlies for the past week have crashed when redirects
occur.  I have been able to reproduce it consistently with
www.valentineone.com/home.asp and clicking on the "upgrades" tab.  I have also
seen it when logging into UPS.com, and netflix.com, though the latter was not
consistent.  Sites are thus unusable.

TBs included from two different nightlies.
stephend, would you get a stack?  (TB882536W, TB843261Z)

Updated

16 years ago
Keywords: crash, stackwanted
Summary: redirects appear to case crashes (TB882536W, TB843261Z) → redirects appear to cause crashes (TB882536W, TB843261Z)
(Reporter)

Comment 2

16 years ago
Reproduced with 2001122703.  See TB957199K.  See an www.avantgo.com.

Appears not to be bug 115527 (seen since that was marked fixed).
here's the talkback info:

Stack Signature  0x61562c13 d1ffbd1f
Trigger Time 2001-12-25 07:52:03
Email Address daveg@psyton.com
URL visited www.valentineone.com/home.asp
User Comments clicked on "upgrades" Seen on redirects on other sites; UPS,
Netflix, Amazon. Has occurred over the past several nightly builds.
Build ID 2001122411
Product ID MozillaTrunk
Platform
Operating System Win32
Module
Trigger Reason Access violation
Stack Trace
0x61562c13
nsCacheMetaData::HashKey
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheMetaData.cpp, line 225]
PL_DHashTableOperate [d:\builds\seamonkey\mozilla\xpcom\ds\pldhash.c, line 482]
0xa0246c8d 


->networking:cache
Assignee: pchen → gordon
Component: XP Apps → Networking: Cache
Keywords: stackwanted
QA Contact: sairuh → tever
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 115672 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.