can't login with admin account after installation

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: allan, Unassigned)

Tracking

4.4.8

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

Steps to reproduce:

I installed bugzilla on mysql and ubuntu 15.04.  I successfully ran checksetup.pl.  I then set my password.  I then tried to login, it failed.  I then tried to reset my password with checksetup.pl and the script ran successfully I then tried to login, failed!


Actual results:

I receive a message 
An unexpected error occurred. This could be a temporary problem, or some code is behaving incorrectly. If this problem persists, please email this page to allan@leoparddata.com with details of what you were doing at the time this message appeared.  The version is actually 4.4.9.

URL: http://130.211.137.185/index.cgi

There was an error sending mail from 'bugzilla-daemon' to 'allan@leoparddata.com': Couldn't find 'sendmail' executable in your PATH and Email::Send::Sendmail::SENDMAIL is not set
Traceback:

 at Bugzilla/Mailer.pm line 174.
	Bugzilla::Mailer::MessageToMTA(...) called at Bugzilla/Token.pm line 299
	Bugzilla::Token::Cancel(...) called at Bugzilla/Token.pm line 315
	Bugzilla::Token::DeletePasswordTokens(...) called at Bugzilla/Auth/Verify/DB.pm line 63
	Bugzilla::Auth::Verify::DB::check_credentials(...) called at Bugzilla/Auth/Verify/Stack.pm line 53
	Bugzilla::Auth::Verify::Stack::check_credentials(...) called at Bugzilla/Auth.pm line 57
	Bugzilla::Auth::login(...) called at Bugzilla.pm line 326
	Bugzilla::login(...) called at /var/www/html/index.cgi line 25


Expected results:

I should be able to login.

Comment 1

3 years ago
This is a support question. See http://www.bugzilla.org/support for help.

  "Couldn't find 'sendmail' executable"

is a pretty explicit error message.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

3 years ago
Um.... so you don't consider it a bug in your solution that you in great detail lay out all that needs to be configured and installed, then right after install, the system crashes due to a missing dependency?  What is the fix if this is so obvious?

Comment 3

3 years ago
Please visit http://www.bugzilla.org/support. And yes, this is definitely not a bug in Bugzilla.
(Reporter)

Comment 4

3 years ago
I appreciate you responding to me but I don't think you get the issue.  Right after installation of this software I could not login with my admin account so I pressed retrieve password.  This appears to have caused the site to try to email me when the email settings are not setup.  I believe this IS a bug because you guys should detect that I have never logged in with the admin account and it is trying to use email settings that do not exist.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 5

3 years ago
Let me be especially explicit.  I have never  been able to login as admin to the site to change the email settings.  But if I try to login as admin it complains about no email settings.  It is a catch 22.

Comment 6

3 years ago
(In reply to Allan Edwards from comment #0)
> I installed bugzilla on mysql and ubuntu 15.04.

How? There are many ways - via Ubuntu's package manager, via downloading a tarball from some website (which one?), via checking out from git, ...

> I then set my password.  I then tried to login, it failed.

Which Perl version is installed, and how?
(Reporter)

Comment 7

3 years ago
I followed your instructions from your bugzilla website.  You guys have a page on installation.  It links to the ubuntu instructions.  I followed that totally and all worked well until I hit this email problem.  My perl version was 5.20.*.

I FINALLY figured out how to make this software work.  I found a posting online about the smtp settings.  Since my admin account NEVER allowed me to login because of invalid email settings I went into the data/params file and modified the smtp server to go to my gmail smtp server.  What is interesting is right after I had the smtp settings right I was able to login to the site with the admin account.  So basically you guys either have a defect with your documentation or you need to rework your code slightly to account for the admin account being unable to login to without a valid and working email configuration for SMTP.

Comment 8

3 years ago
(In reply to Allan Edwards from comment #7)
> you need to rework your code slightly to account for
> the admin account being unable to login to without a valid and working email
> configuration for SMTP.

Email settings are totally unrelated to logins, so this is really a support question. Please do not reopen!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.