webwewant.mozilla.org not loading data

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jon, Assigned: pmac)

Tracking

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/1275] , URL)

(Reporter)

Description

3 years ago
When I load https://webwewant.mozilla.org I don't see any download pings on the map because the data is 404ing:

GET https://glow.cdn.mozilla.net/static/data/stats/1432147440.json [HTTP/1.1 404 Not Found 409ms]

Updated

3 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/1275]
:pmac, is this expected behavior for webwewant right now? If so, this bug can be RESOLVED INVALID; if not, I guess repairs are required.
Flags: needinfo?(pmac)
This is because :jakem turned off the syslog going to the glow servers in https://bugzilla.mozilla.org/show_bug.cgi?id=1140742#c8. We could turn it back on, but I'm not sure if we want that. I'm NI Ben Sternthal to see if we can figure out whether we need this going again.
Flags: needinfo?(pmac) → needinfo?(bsternthal)
(Reporter)

Comment 3

3 years ago
Ah okay, thanks for figuring that out :pmac!

It's not necessary to get it going again, but what are the chances that there's some archived data left on the server? My plan is to get a day's worth of data, and then run a static copy of webwewant.m.o because it's useful for advocacy work. If there's no archived data available, could you update this bug? Thanks!
Altering need info per comment 3
Flags: needinfo?(bsternthal) → needinfo?(pmac)
:jbuck, we have a lot of archived data. You'll have no problem.
Flags: needinfo?(pmac)
(Reporter)

Comment 6

3 years ago
:pmac has sent me some archived data, so I think we can close this bug as wontfix. Thanks everyone!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Updated

3 years ago
Duplicate of this bug: 1189929

Comment 8

3 years ago
Re-opening.

Originally we thought MoFo would be taking this over in a timely manner, however this is not the case.

I am not comfortable with this site being live this long and in a broken state. I think our options are:

1. Decommission the site and repoint the url, perhaps to a page on mozilla.org. When MoFo is ready the site can be fixed and put live again.

2. Duct tape the site to display historical / not break until MoFo properly takes it over.
Either is fine with Webops; we're available to decom if you choose that. Reopning as noted and setting needinfo? to reflect the pending decision (since Webops has no say here).
Status: RESOLVED → REOPENED
Flags: needinfo?(bsternthal)
Resolution: WONTFIX → ---

Updated

3 years ago
Assignee: server-ops-webops → pmac
Flags: needinfo?(bsternthal)

Comment 10

3 years ago
I think we are going to go with #2 and Pmac will address when he is back from PTO.
Component: WebOps: IT-Managed Tools → glow.mozilla.org
Product: Infrastructure & Operations → Websites
QA Contact: smani
I've got it serving data from back around May 1, 2014. It's got around 2 days worth of data to go through before it runs out. Let me know if this looks good or if there is another chunk of data we'd rather use.

Ali: Give it a look and see if it'll work for you.

https://webwewant.mozilla.org/
Flags: needinfo?(aalmossawi)
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
I just updated it again to use data from a few days later when there was a lot more activity. Looks better I think.

Comment 13

3 years ago
Looks great, pmac. Thanks.

Updated

3 years ago
Flags: needinfo?(aalmossawi)
You need to log in before you can comment on or make changes to this bug.