Closed Bug 1168590 Opened 5 years ago Closed 4 years ago

Unreachable code in QuotaClient::CheckIntegrity()

Categories

(Core :: Storage: IndexedDB, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1256593
Tracking Status
firefox41 --- affected

People

(Reporter: mccr8, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: coverity, Whiteboard: [CID 1299625])

Coverity pointed this out.  changedForeignKeys always equals !foreignKeysWereEnabled, so in this code the second branch is always false:

    if (changedForeignKeys) {
      nsAutoCString stmtSQL;
      stmtSQL.AssignLiteral("PRAGMA foreign_keys = ");
      if (foreignKeysWereEnabled) {
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1256593
You need to log in before you can comment on or make changes to this bug.