Intermittent browser_ruleview_colorpicker-edit-gradient.js | The gradient has been updated correctly - Got linear-gradient(to left, rgb(255, 0, 102) 25%, rgb(51, 51, 51) 95%, rgb(0, 0, 0) 100%), expected linear-gradient(to left, rgb(1, 1, 1) 25%, rgb(51,

RESOLVED DUPLICATE of bug 1166774

Status

RESOLVED DUPLICATE of bug 1166774
4 years ago
6 months ago

People

(Reporter: KWierso, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
13:46:13 INFO - 5374 INFO TEST-START | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js
13:46:14 INFO - 5375 INFO checking window state
13:46:14 INFO - 5376 INFO Entering test
13:46:14 INFO - 5377 INFO Adding a new tab with URL: 'data:text/html;charset=utf-8,rule view color picker tooltip test'
13:46:14 INFO - 5378 INFO Loading the helper frame script chrome://mochitests/content/browser/browser/devtools/styleinspector/test/doc_frame_script.js
13:46:14 INFO - 5379 INFO URL 'data:text/html;charset=utf-8,rule view color picker tooltip test' loading complete
13:46:14 INFO - 5380 INFO Creating the test document
13:46:14 INFO - 5381 INFO Opening the rule-view
13:46:14 INFO - 5382 INFO Opening the inspector
13:46:14 INFO - 5383 INFO Opening the toolbox
13:46:14 INFO - 5384 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "resource://gre/modules/devtools/server/actors/highlighter.css" line: 272 column: 15 source: " text-anchor: left;"}]
13:46:14 INFO - 5385 INFO Making sure that the toolbox's frame is focused
13:46:14 INFO - 5386 INFO Waiting for the inspector to update
13:46:14 INFO - 5387 INFO Selecting the ruleview sidebar
13:46:14 INFO - 5388 INFO Testing that the colors in gradient properties are parsed correctly
13:46:14 INFO - 5389 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | The background-image gradient declaration was found
13:46:14 INFO - 5390 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | The color swatch elements were found
13:46:14 INFO - 5391 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | There are 3 color swatches
13:46:14 INFO - 5392 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | The color elements were found
13:46:14 INFO - 5393 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | There are 3 color values
13:46:14 INFO - 5394 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | The right color value was found
13:46:14 INFO - 5395 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | The right color value was found
13:46:14 INFO - 5396 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | The right color value was found
13:46:14 INFO - 5397 INFO Testing that changing one of the colors of a gradient property works
13:46:14 INFO - 5398 INFO Getting the color picker tooltip and clicking on the swatch to show it
13:46:14 INFO - 5399 INFO Getting the spectrum colorpicker object
13:46:14 INFO - 5400 INFO Setting the new color
13:46:14 INFO - 5401 INFO Applying the change
13:46:14 INFO - 5402 INFO Waiting for rule-view to update
13:46:14 INFO - 5403 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | The color swatch's background was updated
13:46:14 INFO - 5404 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | The color text was updated
13:46:14 INFO - 5405 INFO TEST-UNEXPECTED-FAIL | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | The gradient has been updated correctly - Got linear-gradient(to left, rgb(255, 0, 102) 25%, rgb(51, 51, 51) 95%, rgb(0, 0, 0) 100%), expected linear-gradient(to left, rgb(1, 1, 1) 25%, rgb(51, 51, 51) 95%, rgb(0, 0, 0) 100%)
13:46:14 INFO - Stack trace:
13:46:14 INFO - chrome://mochikit/content/browser-test.js:test_is:925
13:46:14 INFO - chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js:testPickingNewColor:70
13:46:14 INFO - self-hosted:InterpretGeneratorResume:716
13:46:14 INFO - self-hosted:next:624
13:46:14 INFO - Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:887:23
13:46:14 INFO - this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:766:7
13:46:14 INFO - this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:707:39
13:46:14 INFO - Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:707:7
13:46:14 INFO - this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:729:7
13:46:14 INFO - this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:687:7
13:46:14 INFO - Front<.onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/protocol.js:1217:7
13:46:14 INFO - DebuggerClient.prototype.onPacket@resource://gre/modules/devtools/dbg-client.jsm:977:7
13:46:14 INFO - LocalDebuggerTransport.prototype.send/<@resource://gre/modules/devtools/dbg-client.jsm -> resource://gre/modules/devtools/transport/transport.js:561:11
13:46:14 INFO - makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:82:14
13:46:14 INFO - makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:82:14
13:46:14 INFO - 5406 INFO Leaving test
13:46:15 INFO - MEMORY STAT vsize after test: 1223360512
13:46:15 INFO - MEMORY STAT residentFast after test: 270245888
13:46:15 INFO - MEMORY STAT heapAllocated after test: 98855720
13:46:15 INFO - 5407 INFO TEST-OK | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-edit-gradient.js | took 2009ms
13:46:15 INFO - 5408 INFO TEST-START | browser/devtools/styleinspector/test/browser_ruleview_colorpicker-hides-on-tooltip.js
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1166774

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.