we need to add a new keyword 'led' for KeyLayoutMap

RESOLVED FIXED in Firefox 41, Firefox OS v2.2

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: viralwang, Assigned: viralwang)

Tracking

unspecified
2.2 S14 (12june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox41 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
we expect we can use Generic.kl for keycode mapping but we can load it since there's a new keyword 'led'
we will get the error log as below

E/KeyLayoutMap(16416): /system/usr/keylayout/Generic.kl:431: Expected keyword, got 'led'.
(Assignee)

Comment 1

3 years ago
Created attachment 8611075 [details] [diff] [review]
add 'led' for KeyLayoutMap scan code

Hi Michael,

I only update partial code for the new keyword 'led', then we can use the Generic.kl file directly.
Attachment #8611075 - Flags: review?(mwu)
(Assignee)

Updated

3 years ago
Assignee: nobody → vwang

Comment 2

3 years ago
Is there a git commit on the Android side which this corresponds to? Or a set of commits?
(Assignee)

Comment 3

3 years ago
Hi Michael,

Most of changes come from this commit: https://android.googlesource.com/platform/frameworks/native/+/74bdd2e7ceabd3c9e74ccf7c2e6bd3dae27ca497
Android move it to KeycodeLabels.h in following commit but I think we only need few things to make it work.
https://android.googlesource.com/platform/frameworks/native/+/872db4f11e407accccba9d37c335ef7e3597eba4

Thank you :)

Comment 4

3 years ago
Comment on attachment 8611075 [details] [diff] [review]
add 'led' for KeyLayoutMap scan code

Review of attachment 8611075 [details] [diff] [review]:
-----------------------------------------------------------------

Ok. Please put the information about where you got this in the commit message.

We should probably just drop in a new copy of Android input code at some point and pickup all the updates.
Attachment #8611075 - Flags: review?(mwu) → review+
(Assignee)

Comment 5

3 years ago
Created attachment 8614504 [details] [diff] [review]
add 'led' for KeyLayoutMap scan code (v2)

update commit message for landing
Attachment #8611075 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/bdc2ca02b080
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S14 (12june)
(Assignee)

Updated

3 years ago
blocking-b2g: --- → 2.2?
(Assignee)

Comment 9

3 years ago
Hi Josh,

I think we need this fix for v2.2 since we can't use power key to wake up flame-l with v2.2 now.
With this gecko fix, we can use correct key mapping for flame-l.
Thank you :)
Flags: needinfo?(jocheng)

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+
status-b2g-v2.2: --- → affected
status-b2g-v2.5: --- → fixed
status-b2g-master: --- → fixed
Flags: needinfo?(jocheng)
Please request b2g37 approval on this patch when you get a chance.
Flags: needinfo?(vwang)
(Assignee)

Comment 11

3 years ago
Comment on attachment 8614504 [details] [diff] [review]
add 'led' for KeyLayoutMap scan code (v2)

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): NA
User impact if declined: we need this fix for v2.2 since we can't use power key to wake up flame-l with v2.2 now. With this gecko fix, we can use correct key mapping for flame-l.
Testing completed: local test is fine.
Risk to taking this patch (and alternatives if risky): Low. 
String or UUID changes made by this patch: NA
Flags: needinfo?(viralwang)
Attachment #8614504 - Flags: approval-mozilla-b2g37?

Updated

3 years ago
Attachment #8614504 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
status-b2g-v2.5: fixed → ---
Duplicate of this bug: 1168304
You need to log in before you can comment on or make changes to this bug.