[Webconverger] Some printing functionality is not currently available since Firefox 38

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
3 years ago
4 months ago

People

(Reporter: Kai Hendry, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.9 Safari/537.36

Steps to reproduce:

Printing in 38 or 39 (tested firefox-39.0b1.tar.bz2) fails.

This is a regression as it used to work find in Firefox 37.



Actual results:

Fails to print / spool the job to the printer.

http://s.natalian.org/2015-05-27/some-printing-functionality-is-not-currently-available.png


Expected results:

Should have printed. I verified the underlying system's CUPS is configured, by spooling a job successfully via lpr.
(Reporter)

Comment 1

3 years ago
This is an issue on Debian 8.0 32 bit linux. I have narrowed down the bug to the point I only changed the browser from https://download.mozilla.org/?product=firefox-XXXX-SSL&os=linux to narrow it down.

Comment 2

3 years ago
Created attachment 8611295 [details]
Screenshot in the description

1. Does it also fail in the latest Nightly in a brand new profile?
https://nightly.mozilla.org
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles

2. Does Print Preview work?

3. Are there any relevant errors in the Browser Console?
https://developer.mozilla.org/docs/Tools/Browser_Console

4. Could you find the regression range? Last 37 Nightly is dated 2015-01-12 (03-02-01). First 38 Nightly is dated 2015-01-12 (12-38-47).
http://mozilla.github.io/mozregression/
Flags: needinfo?(hendry)

Updated

3 years ago
Component: Untriaged → Printing: Output
Keywords: regressionwindow-wanted
Product: Firefox → Core
(Reporter)

Comment 3

3 years ago
Apologies for the trouble. I believe I've narrowed down the problem, to our Webconverger extension breaking from 37-38. https://github.com/Webconverger/webconverger-addon/issues/56
Flags: needinfo?(hendry)

Comment 4

3 years ago
Did something change about printing on Linux?

In particular that it does something in content or requires access to a new chrome URL?

Updated

3 years ago
Component: Printing: Output → Extension Compatibility
Keywords: regressionwindow-wanted
Product: Core → Firefox
Summary: Some printing functionality is not currently available since Firefox 38 → [Webconverger] Some printing functionality is not currently available since Firefox 38

Comment 5

4 months ago
With WebExtensions being the only valid way of doing extensions in Firefox 57, I don't think this bug is still relevant.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.