Closed Bug 1168747 Opened 5 years ago Closed 5 years ago

Intermittent 336736-1a.html | application timed out after 330 seconds with no output

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla41
Tracking Status
firefox39 --- unaffected
firefox40 --- unaffected
firefox41 --- fixed
firefox-esr31 --- unaffected
firefox-esr38 --- unaffected
b2g-v2.2 --- unaffected
b2g-master --- fixed

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: intermittent-failure)

b2g_emulator_vm mozilla-inbound opt test reftest-14

https://treeherder.mozilla.org/logviewer.html#?job_id=10183298&repo=mozilla-inbound

21:03:16 WARNING - TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/marquee/336736-1a.html | application timed out after 330 seconds with no output 

problem seems to be that this times out everytime at around 15 minutes
I'm pretty sure this was provoked into failure by random chunking changes. Dan, this is the first test in the chunk, so something's clearly funky here. Mind taking a look?
Flags: needinfo?(dholbert)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #24)
> I'm pretty sure this was provoked into failure by random chunking changes.
> Dan, this is the first test in the chunk, so something's clearly funky here.
> Mind taking a look?

I have no idea what's going on. :-( The test is static content (no "reftest-wait") with a not-actually-moving <marquee> tag, so there's no clear reason that anything should time out. So I guess something is hanging.

Looks like this is b2g-only, so I'm tempted to say we should add this to the "skip-if(b2g)" pile for now.
Depends on: 336736
(In reply to Daniel Holbert [:dholbert] from comment #35)
> Looks like this is b2g-only, so I'm tempted to say we should add this to the
> "skip-if(b2g)" pile for now.

(Particularly given RyanVM's suspicion that "this was provoked into failure by random chunking changes" [and not by an actual regression].)
Given that the change was from being sixth in the chunk to being first, I'd bet that a) it depends on running after 166591-dynamic-1.html has run and b) you're going to want to do the disabling on Try, because the odds of 336736-1b.html wanting to be the first thing run in the chunk aren't great.

FWIW, the random chunking change (over which I would have backed out, if I'd been willing to stay up later that night) was in https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=7979d6a82bb4ab1f05159ff1cbb21cac8a46f9aa&fromchange=17fc891eb84a&tochange=be715c1edaeb
(In reply to Phil Ringnalda (:philor) from comment #41)
> Given that the change was from being sixth in the chunk to being first, I'd
> bet that a) it depends on running after 166591-dynamic-1.html has run

Maybe, though I'm not sure why that would be the case.

> and b)
> you're going to want to do the disabling on Try, because the odds of
> 336736-1b.html wanting to be the first thing run in the chunk aren't great.

Yeah, they're virtually identical, so I was planning on just disabling both of them.

I'm going to skip Try-investigation, to avoid further delays on this & because I'm not sure how many retriggers we'd need to be sure this has gone away, and I'm just pushing a skip-if(B2G) annotation for 336736-1a.html and 336736-1b.html:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b05f3ca2bb77
Flags: needinfo?(dholbert)
https://hg.mozilla.org/mozilla-central/rev/b05f3ca2bb77
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
You need to log in before you can comment on or make changes to this bug.