debug output possible?

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
enhancement
RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: jg, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011012
BuildID:    2001112516

How about adding a --debug option to mozilla on the command line?

I would be able to make a better guess at which component it was crashing in then..

most other programs  have a --debug or --verbose mode to help working out what's
going on in there, i know i add it to my programs when i do utils

Reproducible: Always
Steps to Reproduce:
1.mozilla --help
2.
3.
There is a -g option which will run mozilla in a debugger.

There is talkback, which will report where you crash so that one can get a 
useful stack even from stripped binaries.

Finally, there is NSPR logging.  Set the environment variable NSPR_LOG_MODULES 
to something like "nsHttp:5" (or "all:5" if you want _lots_ of output).  
Reducing the number from "5" to something smaller to get less verbose output.

What would --verbose do that is not covered by these options?
(Reporter)

Comment 2

16 years ago
nothing, i could not find the documentation on the site for the methods you
sugest before.
resolving worksforme since the logging capabilities exist...

And yes, we do need better documentation.  :(

http://www.mozilla.org/projects/nspr/reference/html/prlog.html#25271 has more 
info on NSPR logging env variables.  The hard part there is getting the module 
name...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

16 years ago
It would certainly make it simpler to give you bug reports if there was a
--verbose option.

Now I have to mess about with env variables when I would rarther be submitting
the bug!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.