Courier New is not rendering correctly for some font sizes

UNCONFIRMED
Unassigned

Status

()

Core
Graphics: Text
UNCONFIRMED
2 years ago
2 years ago

People

(Reporter: Tim Sebring, Unassigned)

Tracking

({fonts})

38 Branch
fonts
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [INVALID?][DUPEME?][gfx-noted])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150513174244

Steps to reproduce:

In pages with the <pre> tag (namely code), an equal sign (=) is rendering as a hyphen (-) for some font sizes. Control mouseup/down would eventually cause the equal sign to render correctly.


Actual results:

Equal sign rendered as hyphen for some font-sizes (controlled with control-mouseup/down). This was seen with FF 37.0.2, and with 38.0.1 (current version as of this report). Workaround was to change Fixed Width font in FF settings to Lucida Console instead of Courier New.


Expected results:

Equal sign should always be rendered as equal sign.
(Reporter)

Comment 1

2 years ago
Created attachment 8611296 [details]
Example of issue (taken from this bug report page)

Comment 2

2 years ago
Created attachment 8611314 [details]
Notepad.png

I get the same result in Notepad, IE 11 and Opera 29. This looks like a bug in the font. I don't see what's to be done here besides fixing bug 468169.

Updated

2 years ago
Component: Untriaged → Graphics: Text
Keywords: fonts
Product: Firefox → Core
Whiteboard: [INVALID?][DUPEME?]
(Reporter)

Comment 3

2 years ago
Interesting -- I don't have that problem in any other application that I've tried so far. I'll do more investigation.
(Reporter)

Comment 4

2 years ago
Notepad, Courier New, size 5 (same as yours) does not exhibit that issue (nor any font size in Notepad).

Comment 5

2 years ago
Please type about:support into the location bar and press Enter. Copy the Graphics section to the clipboard, then paste it in a comment here.

(In reply to Tim Sebring from comment #4)
> Notepad, Courier New, size 5 (same as yours) does not exhibit that issue
> (nor any font size in Notepad).

Whereas I can't reproduce the issue at the font size in your screenshot, only at a smaller size. The result is the same whether HWA is on or off.
I guess this might be because we have different Windows font size settings: mine's “Medium - 125%”.

Updated

2 years ago
Whiteboard: [INVALID?][DUPEME?] → [INVALID?][DUPEME?][gfx-notes]

Updated

2 years ago
Whiteboard: [INVALID?][DUPEME?][gfx-notes] → [INVALID?][DUPEME?][gfx-noted]
You need to log in before you can comment on or make changes to this bug.