Closed Bug 1168954 Opened 8 years ago Closed 8 years ago

Unexpected "Install" button appears on add-on install progress doorhanger

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla41
Tracking Status
firefox39 + verified
firefox40 --- verified
firefox41 --- verified

People

(Reporter: mossop, Assigned: mossop)

References

Details

(Whiteboard: [hijacking][fxsearch])

Attachments

(1 file)

[Tracking Requested - why for this release]:

Because we're not using the doorhanger install confirmation in 39 we shouldn't show the install button disabled in the progress doorhanger.
Blocks: 1139656
Attached patch patchSplinter Review
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #8611413 - Flags: review?(dao)
Flags: firefox-backlog+
Whiteboard: [hijacking][fxsearch]
Comment on attachment 8611413 [details] [diff] [review]
patch

>+      }
>+      else {

nit: on one line please (according to https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Coding_Style#Control_Structures and prevailing style in browser code)
Attachment #8611413 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/1046d1d11e83
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Comment on attachment 8611413 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: 1139656
[User impact if declined]: Beta users will see an odd disabled install button in the add-on progress dialog
[Describe test coverage new/current, TreeHerder]: Only manual testing, the feature is expected on aurora/nightly
[Risks and why]: Low risk, this is a simple pref check to hide a button.
[String/UUID change made/needed]: None

Technically we don't need this on aurora but I'd rather keep the code the same.
Attachment #8611413 - Flags: approval-mozilla-beta?
Attachment #8611413 - Flags: approval-mozilla-aurora?
Tracking since it is affecting Firefox 39
Comment on attachment 8611413 [details] [diff] [review]
patch

Approved for uplift to aurora and beta; this has had time on m-c and is a minor UI fix.
Attachment #8611413 - Flags: approval-mozilla-beta?
Attachment #8611413 - Flags: approval-mozilla-beta+
Attachment #8611413 - Flags: approval-mozilla-aurora?
Attachment #8611413 - Flags: approval-mozilla-aurora+
It would be good to verify this in 39 and 40 just to make sure we haven't done anything weird to 40.
Flags: qe-verify+
QA Contact: vasilica.mihasca
Reproduced this issue on Firefox 39 Beta 1 build 1 ( 20150523155636) using Windows 7 64-bit.

Verified fixed on Firefox 39 Beta 3 (20150604162752) under Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5.

Performed Exploratory testing to make sure that no new issues were caused by this fix in Firefox 41.0a1 (2015-06-07) and Firefox 40.0a2 (2015-06-07). Tested on Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5
You need to log in before you can comment on or make changes to this bug.