Navbar toolbar button order not preserved

RESOLVED INCOMPLETE

Status

()

Core
XUL
RESOLVED INCOMPLETE
3 years ago
2 years ago

People

(Reporter: quality+bugzilla, Unassigned)

Tracking

38 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150513174244

Steps to reproduce:

Use the Customize UI to reorder toolbar buttons in the Navbar.


Actual results:

Toolbar buttons reorder as expected.  But when close Firefox and reopen it, new button order is not maintained.


Expected results:

Button order specified via the Customize UI should be maintained between Firefox sessions.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Component: Untriaged → XUL
Product: Firefox → Core
Hello,

Are you still having issues in newer versions of Firefox?
Flags: needinfo?(quality+bugzilla)
(Reporter)

Comment 2

2 years ago
(In reply to Grover Wimberly IV from comment #1)
> Hello,
> 
> Are you still having issues in newer versions of Firefox?

Good question.  I got tired of having the toolbar button order not being maintained, so I wrote a CSS overlay to force the order.  I've been using that overlay for over half a year.  So I don't know if it's still an issue.

I have read feedback (I think on AMO) from users complaining to extension authors that their toolbar buttons are moving.  The extension authors generally write back that it is a known bug in Firefox and there is nothing the extension author can do to fix it.  So I know many people have experienced this issue, but I don't know whether the issue still exists.

I can try removing the overlay that forces the order, if you like. Just let me know.
Flags: needinfo?(gwimberly)
Please try your original steps in a newer version of FF and see if the issue can be reproduced. Thanks!
Flags: needinfo?(gwimberly)
(Reporter)

Comment 4

2 years ago
Will do.  I'll report back in a few weeks.
Closing bug due to lack of response from the reporter. If you feel this remains pertinent, please report with the requested information per Comment 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

2 years ago
Testing in progress.  So far, bug appears to be fixed.
(Reporter)

Comment 7

2 years ago
Bug initially appeared fixed, but is definitely still present.  Tested and reproduced in Firefox 47.0.1.

Unfortunately, the bug is tricky and likely requires multiple elements to manifest.  I have not had time to create steps to reproduce it from a new profile, and given that I can work around the bug using a CSS overlay, I don't think I'll be making that task a priority.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(quality+bugzilla)
Resolution: INCOMPLETE → ---
Setting back to incomplete based on Comment 7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.