User is not asked for password when resetting payment pin on FFOS 2.1

RESOLVED WORKSFORME

Status

Marketplace
Payments/Refunds
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Madalin Cotetiu, Unassigned)

Tracking

Avenir
2015-05-26
Points:
---

Details

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Open stage app and log in.
2. Search for a paid app and start a purchase.
3. In the Enter pin page click on the Forgot your PIN link and then click on the Reset button

Expected results:
The user is asked to re-authenticate with full username and password.

Actual results:
The Reset Pin page is displayed and the user is asked to sign in. The user has only to click on the Sign in button and after that he is able to reset the pin. The user is not asked for password.

Notes/Issues:
Verified in FFOS 2.1. Issue can be reproduced in mp-stage and production
Hi, can you provide a screencast along with full device info, including the build you are running?

I just tried this with a flame-kk on a freshly installed 2.1 build and I was asked for the password as expected.
Flags: needinfo?(madalin.cotetiu)
(Reporter)

Comment 2

3 years ago
This are the build I reproduced the issue: http://screencast.com/t/iWaCG1G4bT5D
I have flashed the device with the latest 2.1 and couldn't reproduce it any longer.
Flags: needinfo?(madalin.cotetiu)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.