Closed Bug 1169384 Opened 6 years ago Closed 6 years ago

function attributes.getNamedItem() is not able to find attributes created with uppercase letters in name

Categories

(Core :: DOM: Core & HTML, defect)

38 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1165851

People

(Reporter: rbri, Unassigned)

References

Details

Attachments

(1 file)

Attached file getNamedItem.html
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150514102509

Steps to reproduce:

My js code does something like 'document.createAttribute('myAttr');'
Later on i try to get this attribute back by 'attributes.getNamedItem('myAttr')' but this call returns null.

This problem only occures, if the attribute name of the new attribute contains uppercase letters.

Everything works fine with FF31 ESR. This is new to FF38 ESR.

See attached sample, hope this makes the point.


Actual results:

Newly created attribute will not be found (if the name contains uppercase letters).


Expected results:

Newly created attribute should be found.
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1165851
Related, but not quite identical....  getNamedItem doesn't have to have the same behavior as getAttribute, and bug 1165851 is about the latter.

Anne, we've gotten a number of bug reports about this now.  :(  I really think the spec is just not web-compatible here.
Blocks: 1075702
Status: RESOLVED → REOPENED
Component: Untriaged → DOM
Ever confirmed: true
Flags: needinfo?(annevk)
Product: Firefox → Core
Resolution: DUPLICATE → ---
See Also: → 1165851
Please see bug 1165851 comment 23.
Flags: needinfo?(annevk)
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1165851
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.