display an error when user autocompletion fails (eg. due to an expired token)

RESOLVED DUPLICATE of bug 1209148

Status

()

RESOLVED DUPLICATE of bug 1209148
3 years ago
23 days ago

People

(Reporter: kbrosnan, Unassigned)

Tracking

Production

Details

(Reporter)

Description

3 years ago
Searching for names via partials is failing for me most of the time. This is in the search by people section of the advanced search and the cc list for filing new bugs or edting bugs.

:bsmed, :kbros, and ioana cho all use to match users with bugzilla accounts. This is not functioning for me on Firefox 40 and 41. Intermittently it will work, :glob for example matched. :|
i'm unable to make make autocomplete fail even when using the examples you provided.

when it happens are there any javascript errors?
Flags: needinfo?(kbrosnan)
(Reporter)

Comment 2

3 years ago
Seems to be working at the moment. I'll check the next time it comes up. Ran into this either earlier on the 28th or 27th.
Cool. Please file new bug if you see this issue again. Thanks

dkl
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

3 years ago
So I think I know what is going on here. I restore tabs and leave them open for some time. Going into the network inspector I see the following JSON response for every letter I type, "The token is not valid. It could be because you loaded this page more than3 days ago."

Did this behavior change?
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(kbrosnan)
Resolution: INVALID → ---
(In reply to Kevin Brosnan [:kbrosnan] from comment #4)
> Did this behavior change?

this changed about four months ago (via bug 1045145).

the best we can do is expose that error to the user, either directly after a search is performed, or perhaps detecting when a tab is restored and validating the api token.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Autocomplete for people has become much worse since the upgrade → display an error when user autocompletion fails (eg. due to an expired token)

Updated

23 days ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago23 days ago
Component: General → API
Resolution: --- → DUPLICATE
Duplicate of bug: 1209148
You need to log in before you can comment on or make changes to this bug.