If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Consider how app links should be handled in Android M

RESOLVED WONTFIX

Status

()

Firefox for Android
General
RESOLVED WONTFIX
2 years ago
10 months ago

People

(Reporter: snorp, Unassigned)

Tracking

(Blocks: 1 bug)

34 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Android M adds 'app linking', which you can read about here: http://developer.android.com/preview/api-overview.html#app-linking

Brad thinks maybe we should automatically open top-level URLs in the associated app when we encounter one that has a strong link like this. What does UX think?
Ni for Anthony and Margaret to own this decision.
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(alam)
I think users already on M should/will expect this. I've always liked our little Android dude in the toolbar but this goes one step further and the user doesn't even need to tap that. 

I'd be up for doing this for our M users. 

Question: what is a "strong link"? and can we get a build to test this?
Flags: needinfo?(alam) → needinfo?(snorp)
I'm curious how this pans out. The result seems like it might ignore the users selected app for (for example) "twitter.com" links in favor of whatever the official "twitter.com" app is (if its also installed).
There is more info about app linking here: http://developer.android.com/preview/features/app-linking.html

There doesn't appear to be a sample app for this, so we'll need to write one it looks like.
Flags: needinfo?(snorp)

Comment 5

2 years ago
(In reply to Wesley Johnston (:wesj) from comment #3)
> I'm curious how this pans out. The result seems like it might ignore the
> users selected app for (for example) "twitter.com" links in favor of
> whatever the official "twitter.com" app is (if its also installed).

I remember hearing there is a way to override this in your apps settings, but yeah, that's just another hurdle to cross. But maybe most users would want the official app anyway, especially if they have that app installed.

I'm not so sure about whether or not we should automatically open the app for top-level URLs... do you mean we would open the app if the user hits a link to "http://twitter.com" from within the browser? How often would that even happen? And wouldn't that feel inconsistent with links to more specific URLs?

We could make a sample app to play around with this, but I think the final call about the behavior here belongs to Karen and Anthony.
Flags: needinfo?(margaret.leibovic)
Duplicate of this bug: 1170490
App links are handled at the OS level (when launching Intents). So there's not much to do for us.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.