XHR fileupload in multi-process fails with drag-and-drop

RESOLVED DUPLICATE of bug 1166603

Status

()

Core
Drag and Drop
RESOLVED DUPLICATE of bug 1166603
3 years ago
3 years ago

People

(Reporter: wing-tung Leung, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150513174244

Steps to reproduce:

Firefox developer edition (today's version for both MS Windows and MacOS 40.0a2), with multi-process mode enabled.

- Open internal JIRA issue tracking system from company (Mazda Motors Europe)
- Select single issue to display
- Click "Edit" button to open edit dialog
- Open Windows Explorer (or MacOS Finder) and drag file into the "attachment" section


https://mapps.mazdaeur.com/jira/secure/Dashboard.jspa
Atlassian JIRA Project Management Software (v6.3.9#6339-sha1:46fa261)

https://jira.atlassian.com/browse/TST-67728
Atlassian JIRA Project Management Software (v6.5-m04#65000-sha1:ddfafbc:node1) 




Actual results:

On Mazda company JIRA system: red error message is shown just near the attachment upload section with following text:

Cannot attach file list.txt: Unable to communicate with JIRA.

On Atlassian's JIRA issue tracker (newer version) slightly different, also red error message:

Internal server error occurred.

In both cases, Firefox network monitor displays an XHR POST request (showing request headers, cookies, parameters, but NO response at all.

Copy of POST URL which fails (I have feeling that is not really sent out to server):
POST https://mapps.mazdaeur.com/jira/rest/internal/1.0/AttachTemporaryFile?filename=checklist_JMZBK14Z201624119_2015-04-29.pdf&size=954161&atl_token=A0CE-OZ9M-6G08-XVIS|f63b4e73347bccf30ba7b2adfd60a834c1c8b8f9|lin&formToken=809e0bec4724f821cb859417efda78b7f299a8e7&issueId=57910



Expected results:

Expected that on releasing file in correct area, the file content is immediately uploaded to JIRA backend server.

This works fine which turning of multi-process, and fails again when multi-process is re-enabled.

Clicking the old school "browse" input element (NOT using DnD), and selecting file using dialog works fine.

When it works fine (either disabled multi-process or using file selection dialog), the server normally responds with HTTP 201 (CREATED).

No obvious error logged in JavaScript console, only "normal" output:

POST XHR https://mapps.mazdaeur.com/jira/rest/internal/1.0/AttachTemporaryFile

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → Drag and Drop
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1166603
You need to log in before you can comment on or make changes to this bug.