Closed Bug 1169778 Opened 4 years ago Closed 2 years ago

[Aries] FM Radio doesn't work on Sony Xperia Z3

Categories

(Firefox OS Graveyard :: Gaia::FMRadio, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:-, b2g-master affected)

RESOLVED WONTFIX
blocking-b2g -
Tracking Status
b2g-master --- affected

People

(Reporter: dholbert, Unassigned)

References

Details

(Whiteboard: [Spark][aries-l-support])

Tried opening FM Radio on essentially freshly-flashed Sony Xperia Z3.

Plugged in headphones, as directed by the app, and then seeked the dial to a radio station that I'm familiar with (88.5 KQED).

No audio is coming out of the headphones, and the play button just has a spinning blue circle around it.  When I tap the play button, the spinning blue circle goes away, but still no audio plays.

(I also verified that the headphones do indeed work, by successfully playing audio through them in a different app.)
Summary: Radio doesn't work on Sony Xperia Z3 → FM Radio doesn't work on Sony Xperia Z3
Thanks for this report, but this is actually known and we're cutting it from the build.

Just curious, do you want to be able to use the FM Radio, or were you just testing it and noticed this? We've generally been operating on the assumption that most people don't care about it, but if you do, we might be able to shift some people over to getting it working.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(dholbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1169118
(In reply to Doug Sherk (:drs) (use needinfo?) from comment #1)
> Just curious, do you want to be able to use the FM Radio, or were you just
> testing it and noticed this? We've generally been operating on the
> assumption that most people don't care about it, but if you do, we might be
> able to shift some people over to getting it working.

When I've been dogfooding other Firefox OS devices in the past, I've used & enjoyed the FM radio, yeah.  Handy as a quick thing to listen to when doing dishes / laundry / etc.
Flags: needinfo?(dholbert)
Ok, thanks for the feedback. I'm reopening this for now, then.

Mike, I remember that you said that getting the FM radio back-end working would be quite an undertaking on our previously more rushed timelines. Could you clarify what that would involve?
Status: RESOLVED → REOPENED
Flags: needinfo?(mwu)
Resolution: DUPLICATE → ---
Requires some degree of reverse engineering to figure out the hardware interface to the thing, and then figuring out how to slot that into our FM radio code. It's tricky because the broadcom chip requires you to access the FM radio over a bluetooth interface (I assume to reduce the number of pins required), and we want a kernel driver which does the work. Most bluetooth things are normally done in userspace which makes it trickier to make a v4l2 driver for this.
Flags: needinfo?(mwu)
Thanks, Mike. Based on that, could you provide the following info?
- Who would be best person/people to work on this?
- How long would it take, roughly?
- Are we likely to have any instability issues and such due to reverse-engineering the interface?
- Could we provide a working back-end via OTA update in the future, or would it require some firmware-level changes?

We're likely not going to do this before we launch, but it would be great if we could get it working via OTA update eventually.
Flags: needinfo?(mwu)
Blocks: spark-device
Priority: -- → P2
Whiteboard: [spark]
Uh, other than myself, I don't know anyone else who often works at this level. Not impossible to pick up for a sufficiently determined engineer. It'll probably require a boot (kernel) and system image update to roll out. If I did it myself, I'd estimate it would take three weeks.
Flags: needinfo?(mwu)
(In reply to Michael Wu [:mwu] from comment #6)
> Uh, other than myself, I don't know anyone else who often works at this
> level. Not impossible to pick up for a sufficiently determined engineer.
> It'll probably require a boot (kernel) and system image update to roll out.
> If I did it myself, I'd estimate it would take three weeks.

Michael, I am one of those who would like to be able to use FM Radio. If you have anything that could guide me into hacking, I'm happy to try working on this.
Maybe Lollipop will help this, since on KK the bluetooth code that enables FM Radio is in a blob, and on Lollipop we have no more need for Bluetooth blos :)
Duplicate of this bug: 1167000
[Blocking Requested - why for this release]:
FM radio is in scope for 2.5, this is a functional regression from Flame behavior that fails smoke tests.
blocking-b2g: --- → 2.5?
Summary: FM Radio doesn't work on Sony Xperia Z3 → [Aries-L] FM Radio doesn't work on Sony Xperia Z3
Whiteboard: [spark] → [Spark][aries-l-support]
Even if this device supported FM, it wouldn't be a realistic representation of how shipping devices support FM. Test FM on the Flame-KK.
As far as I have been told, we need someone to write a driver for this if we are to support it.  Ken, could you find a developer to look into this please?
Flags: needinfo?(kchang)
Summary: [Aries-L] FM Radio doesn't work on Sony Xperia Z3 → [Aries] FM Radio doesn't work on Sony Xperia Z3
[Triage] We won't be blocked by this bug due to FM Radio implementation on Aries is not the same as other devices.

btw. Since it's not a regression issue, remove regression flag
blocking-b2g: 2.5? → ---
Keywords: regression
wrong flag...my bad
blocking-b2g: --- → -
According to comment 14, it's not a bug with high priority. Let's do it later.
Flags: needinfo?(kchang)
I'd like to remove this bug from smoke test blocker due to we exclude FM radio on Aries now. Please feedback with the reason you still want to have it with smoketest flag.
Keywords: smoketest
Blocks: 1197124
I am one of the very interested in the FM app to work as I have long bus travels to/from work and I entertain myself a lot with that app. I was very disappointed to realize it was missing from the foxfooding device I received in Orlando's all hands.
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 4 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.