Crash when moving bookmarks around within a folder

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: kitty, Assigned: paulkchen)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Linux)
BuildID:    2001122608

Open the bookmarks editor and open a folder. Drag a bookmark and try to place it
precisely between two bookmarks. 

Bug #1 I am not able to place a bookmark between two bookmarks within the same
folder. It seems to take an offset +/- 2 bookmarks. 
Bug #2 While trying hard to place it between two bookmarks, the browser crashed. 


Reproducible: Always
Steps to Reproduce:
1.Open bookmarks editor.
2.Try to place a bookmark between two bookmarks.
3.

Actual Results:  Browser crash. When not crashing the bookmark is off by 2.

Expected Results:  I should be able to place a bookmark between any two bookmarks.

I will try to attach the talkback information. Sorry I don't know how to get a
talkback identifier. The help link in the talkback window that appears is broken.
(Reporter)

Comment 1

17 years ago
Created attachment 62783 [details]
Talkback information saved when the browser crashed

Here's the talkback information.
Reporter: Can you give us the talkback ID ?
(run mozilla/bin/components/talkback manually to get the ID)
Severity: major → critical
Keywords: crash
(Reporter)

Comment 3

17 years ago
Ah..I didn't know about that. Is this documented somewhere ? 

The talkback identifier is TB926435Z. Hope this helps.
CC Stephend for talkback :TB926435Z

>Is this documented somewhere ? 
no,AFAIK



Stack Signature  nsWindow::OnDragMotionSignal() 79c66029
Trigger Time 2001-12-26 16:45:22
Email Address kitty@cs.wustl.edu
URL visited
User Comments Play around with arranging the bookmarks within a folder.
Especially try to place a particular bookmark precisely. For example in between
two bookmarks.
Build ID 2001122608
Product ID MozillaTrunk
Platform
Operating System LinuxIntel
Module
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
Stack Trace
nsWindow::OnDragMotionSignal()
nsWindow::FireDragMotionTimer()
nsWindow::DragMotionTimerCallback()
nsTimerImpl::Process()
handleMyEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xff9e (0x40389f9e)
libglib-1.2.so.0 + 0x11773 (0x4038b773)
libglib-1.2.so.0 + 0x11d39 (0x4038bd39)
libglib-1.2.so.0 + 0x11eec (0x4038beec)
libgtk-1.2.so.0 + 0x94333 (0x402a6333)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1c627 (0x404d2627) 

Comment 6

17 years ago
*** Bug 116189 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Confirming based on duplicate.

Reporter, are you still seeing this on a recent build?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

17 years ago
*** Bug 115936 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Issue 1 you described is bug 114606.  Please keep it to one issue per bug
report.
(Reporter)

Comment 10

17 years ago
No it doesn't crash anymore. I am running Build 2002011015. However, I am still
not able to place a bookmark between two bookmarks. So if you want to close this
and track 114606, it should be fine.

Comment 11

17 years ago
Thanks!

Resolving based on reporter's comments.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.