bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

When a Firefox OS device is mounted over USB via MTP, files are shown with bogus datestamps from mid-twentieth century e.g. 1940, 1950, 1965

RESOLVED DUPLICATE of bug 1167090

Status

Firefox OS
MTP/UMS
RESOLVED DUPLICATE of bug 1167090
3 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR:
 1. Take some photos / screenshots on a B2G phone, so you have a DCIM directory at least.
 2. In Settings, enable USB Storage, and in USB storage's settings, tap "Media transfer protocol (MTP)"
 3. Connect your phone to a computer over USB. (I'm connected to a laptop running Ubuntu 15.04)
 4. Browse the device in your computer's file viewer, and look at the timestamps.

ACTUAL RESULTS: The timestamps are randomly distributed in the 1940's, 50's, and 60's.

EXPECTED RESULTS: Meaningful timestamps.


If I connect to the device using "adb shell" and use "ls -l" to inspect timestamps on the device locally, they look reasonable -- so I think this is specifically a bug with MTP and/or USB.
(Reporter)

Comment 1

3 years ago
Created attachment 8613108 [details]
screenshot, showing both "adb shell" w/ reasonable timestamps, & file browser w/ 1900's timestamps
(Reporter)

Comment 2

3 years ago
Testing on a Sony Xperia Z3, with a Firefox OS 3.0 build on it.
  Build Identifier: 20150528210322
  Update channel: dogfood
  Git commit info: 2015-05-28 19:50:18   18f7c340


My OnePlus One phone (running CyanogenMod Android lollipop) gives EXPECTED REUSLTS, when I browse photos on it from the same laptop (also with a USB/MTP connection). So I think that means it's an issue with the phone/b2g, not with my laptop.
(Reporter)

Updated

3 years ago
Summary: B2G device, mounted over USB via MTP, shows files with bogus datestamps from mid-twentieth century e.g. 1940, 1950, 1965 → Sony Xperia Z3 w/ B2G, mounted over USB via MTP, shows files with bogus datestamps from mid-twentieth century e.g. 1940, 1950, 1965
(Reporter)

Comment 3

3 years ago
I see this same issue on a Flame device which I just updated to the latest b2g 3.0 nightly, too.

(The flame previously had a 2.1 nightly on it, and with that build, the flame simply wouldn't mount with MTP. With 3.0, it mounts & exhibits this bug.)

So, this doesn't seem to be device-specific.
Summary: Sony Xperia Z3 w/ B2G, mounted over USB via MTP, shows files with bogus datestamps from mid-twentieth century e.g. 1940, 1950, 1965 → When a Firefox OS device is mounted over USB via MTP, files are shown with bogus datestamps from mid-twentieth century e.g. 1940, 1950, 1965
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1174427
(Reporter)

Updated

3 years ago
Component: Gaia::System → MTP/UMS
I think this is a dupe of Bug 1146900 - at least that is what my bug got duped to me.
(Reporter)

Comment 6

3 years ago
Thanks. I don't really understand what's going on there, but I'll trust aosmond's duping of your bug & follow suit.  (I also extended the summary of that bug to hopefully make it more discoverable & reduce the number of dupes that are filed.)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1146900
Duplicate of bug: 1167090
You need to log in before you can comment on or make changes to this bug.