browser do not show html body when server report status 500

UNCONFIRMED
Unassigned

Status

()

Core
Networking: HTTP
P3
normal
UNCONFIRMED
3 years ago
9 months ago

People

(Reporter: Eugen Konkov, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8613239 [details]
Sharp answer and request handler

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150511103818

Steps to reproduce:

respond from server with big body (4505 bytes) with status 500

details is here
https://bz.apache.org/bugzilla/show_bug.cgi?id=57976

feel free to ask more info if you need


Actual results:

Blank page is displayed and connection to server is closed in wrong way


Expected results:

I expect to see page body and I do not expect mod_perl2 thread do not exit.
So I need to reboot server each time when more errors happen.

[Sat May 30 16:03:07.357950 2015] [core:warn] [pid 26565:tid 140189391525760] AH00045: child process 24496 still did not exit, sending a SIGTERM
[Sat May 30 16:03:09.360153 2015] [core:warn] [pid 26565:tid 140189391525760] AH00045: child process 24496 still did not exit, sending a SIGTERM
[Sat May 30 16:03:11.362370 2015] [core:warn] [pid 26565:tid 140189391525760] AH00045: child process 24496 still did not exit, sending a SIGTERM

Updated

3 years ago
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
Whiteboard: [necko-backlog]
You need to log in before you can comment on or make changes to this bug.