Firefox 38 Preferences Not Readable when using dark theme

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: drankinatty, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8613263 [details]
preferences_unreadable.jpg

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 2015051400

Steps to reproduce:

Attempting to access preferences after install of FF 38.01 on openSuSE I discovered there is no longer a preferences window, but instead another webified widget as the interface to preferences. The contents are unreadable with a dark theme.


Actual results:

Attempting to check cookies due to an issue with openSSL.org, I discovered I cannot see my cookies any more due the web page interface incorrectly applying some dark theme to the cookie list (see attached screenshot)


Expected results:

I should have been able to read the preferences and the list of cookies so I could debug the openssl.org cookie issue. The normal preferences widget should have appeared which would have avoided this issue entirely. The web interface to preferences makes the preferences impossible to read due to its mishandling of dark color theme settings. 

(that is why you don't webify settings and preferences because you risk making them impossible to use due to varying color and theme settings on different OSs and desktops)

Is there an about:config setting I can use to get the old preferences dialog back and see my cookies while this bug is looked at?

Updated

4 years ago
Component: Untriaged → Preferences
(Reporter)

Comment 1

3 years ago
Created attachment 8627396 [details]
cant_read_about-config.jpg (about:config unreadable as well)

I just found that about:config is not readable as well. It is almost impossible to use Firefox with the same dark themes that have been used for the past 5 years. Whatever new UI has been added, needs to be rolled back. Whatever the intent, it makes Firefox difficult, if not impossible, to use for a large number of users. Firefox should revert to the prior dialog and user interface that can be read regardless of desktop theme.

Comment 2

3 years ago
These are the new tabbed/in context variations of those interfaces.
You do not mention having tested in safe mode, which should be done as part of submitting your crash report.
The problem is likely caused by the theme, which is the responsibility of the theme author.
If you can reproduce insafe mode then please reopen the bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Summary: Firefox 38 Preferences Not Readable → Firefox 38 Preferences Not Readable when using dark theme
You need to log in before you can comment on or make changes to this bug.