CSS display:none cannot be overridden on <svg>

RESOLVED DUPLICATE of bug 376027

Status

()

RESOLVED DUPLICATE of bug 376027
4 years ago
4 years ago

People

(Reporter: kganser, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8613329 [details]
svg_bug.html

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

Steps to reproduce:

Apply display:none to an svg element included in an html document via <use>. Try applying display:inline to the same element with a selector of higher precedence.  The svg will not display.

Displays fine on latest Chrome and IE.  Tested on FF 38.0.1.  See attached test case


Actual results:

SVG does not display


Expected results:

SVG displays
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376027
Make the SVG you want to hide a child of <defs> rather than display:none for a cross-browser result
(Reporter)

Comment 3

4 years ago
The workaround was not to use `svg` in the CSS selectors when applying display:none, which made is overridable. Adding <defs> didn't seem to have any effect.
You need to log in before you can comment on or make changes to this bug.