Sync incorrectly reports a prolonged error.

RESOLVED FIXED in Firefox 39

Status

()

defect
RESOLVED FIXED
4 years ago
11 months ago

People

(Reporter: markh, Assigned: markh)

Tracking

({regression})

unspecified
mozilla41
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox38 wontfix, firefox38.0.5 wontfix, firefox39 fixed, firefox40+ fixed, firefox41 fixed)

Details

Attachments

(1 attachment)

Somewhat embarrassingly, browser-syncui will think every Sync error is a "prolonged" error if that profile has ever previously synced with the now disabled "readinglist", as the last successful RL sync was well over 2 weeks ago.

Profiles that never configured RL are not affected.

isProlongedReadingListError() should return false if readinglist.scheduler.enabled is false.

(I'm not putting up a patch yet, as I can still see this errorbar remain even when Sync subsequently completes successfully, and I'm trying to work out why that's the case)
Mark: please double-check my tracking flags!
Regression from bug 1131413 which landed on 38
Drew, this is a regression from when we changes browser-syncui to support the reading list.  If a profile has ever done a reading-list sync in the past but now has the reading-list disabled we act as though there is a "prolonged" sync error. This patch ignores the last-sync date if the reading-list scheduler is disabled.
Assignee: nobody → markh
Status: NEW → ASSIGNED
Attachment #8614528 - Flags: review?(adw)
Attachment #8614528 - Flags: review?(adw) → review+
https://hg.mozilla.org/mozilla-central/rev/927f0de4430c
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Comment on attachment 8614528 [details] [diff] [review]
0002-Bug-1170079-don-t-treat-an-old-readinglist-last-sync.patch

Approval Request Comment
[Feature/regressing bug #]: reading list regression
[User impact if declined]: Sync will show an infobar telling them Sync hasn't completed for 2 weeks, which is incorrect.
[Describe test coverage new/current, TreeHerder]: New test
[Risks and why]: Very low, limited to the Sync UI
[String/UUID change made/needed]: None
Attachment #8614528 - Flags: approval-mozilla-beta?
Attachment #8614528 - Flags: approval-mozilla-aurora?
Comment on attachment 8614528 [details] [diff] [review]
0002-Bug-1170079-don-t-treat-an-old-readinglist-last-sync.patch

Approved for uplift to aurora and beta.
Attachment #8614528 - Flags: approval-mozilla-beta?
Attachment #8614528 - Flags: approval-mozilla-beta+
Attachment #8614528 - Flags: approval-mozilla-aurora?
Attachment #8614528 - Flags: approval-mozilla-aurora+
Keywords: regression
Since this was fixed and approved for uplift, I went ahead and tracked for 40, to make sure it is resolved there.
Duplicate of this bug: 1206026
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.