[System] The task manager does not show the screenshot of the whole app when the keyboard was displayed

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
9 months ago

People

(Reporter: julienw, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Here is a STR to reproduce this issue:

1. Launch the SMS app.
2. Press the "new message" button.
3. Tap the Composer so that the keyboard is displayed.
4. Press Home to go back to the homescreen.
5. Long press Home to show the Task Manager.

=> The screenshot only shows part of the app.

QA: can you please do a branch checks ? Thanks !
Created attachment 8613804 [details]
screenshot of issue

This issue is not a regression and occurs on all branches including on v18D-1 base image only. With keyboard on screen in Messages app, going Home and then bringing up Task Manager will show that Messages app's screenshot is not of the whole app.

See screenshot for bug behavior.

Device: Flame (KK, full flashed, 319MB)
BuildID: 20150601010203
Gaia: e6dc0f4c583407a4a52a66ce7cb11f058302a762
Gecko: f8d21278244b
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Device: Flame (KK, full flashed, 319MB)
BuildID: 20150601002502
Gaia: b4582cc394e0919623263997c0cdb0b4751a1403
Gecko: 78d8b0a4303d
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame (KK, full flashed, 319MB)
BuildID: 20150601001204
Gaia: 2304a1f6327c2ccf35d6995ee16f2231ed1f22a3
Gecko: e52807dee101
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame (KK, full flashed, 319MB)
BuildID: 20150601000202
Gaia: 5552bf529d3d6775a968942e9afa6c1d4037362c
Gecko: a592339c2d65
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Note that this also impacts edge gesture, since the issue is with the appWindow's screenshot.

We probably need to make sure the appWindow is resized before we take the screenshot.
Component: Gaia::System::Task Manager → Gaia::System::Window Mgmt

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][Low_QA]

Comment 3

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.