Sometimes the screen to connect to a hidden network doesn't have the OK button enabled

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: kats, Assigned: evanxd)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

Attachments

(3 attachments)

A couple of times now on recent m-c builds on the Flame I've observed this behaviour:

- Go into settings, wi-fi
- Go the screen to add a network SSID manually
- Select "none" from the encryption method dropdown
- Enter a network name in the text box

At this point I want to hit the OK button in the top-right of the screen but it is disabled. It seems to happen sometimes but not always. Usually backing out and then going back into the screen will fix it.
It's very similar to bug 949152, except not in the FTU and more intermittent.
See Also: → bug 949152
[Blocking Requested - why for this release]: regression
blocking-b2g: --- → 3.0?
Keywords: regression

Comment 3

3 years ago
Please help to confirm we can reproduce this issue, thanks.
Keywords: qawanted
This bug seems to be duplicate with Bug 1173309.
See Also: → bug 1173309
blocking-b2g: 2.5? → 2.5+
I was unable to reproduce this issue on either latest Aries or Flame KK builds.  Leaving the tag for someone else to try.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150817205547
Gaia: 60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gecko: 9673c75864beafca2f6c8b117b98503128bf2e56
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20150817061040
Gaia: 60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gecko: a6eeb28458fd2652e12e57334f046b7776d75bb4
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
I was able to reproduce the bug on latest Aries and Flame.

STR:
0) DUT is already connected to a regular wifi network. Settings is NOT running.
1) Go to Settings > Wifi > Manage Networks > Join Hidden Network
2) Tap on the dropdown for Security, and select 'WEP'
3) Tap on the dropdown again, this time select 'None'
4) Tap the field for SSID Network Name, and type in some characters

- Observe the OK button on upper right grays out and tapping on it does nothing

Repro rate: 5/5

Video demonstrating the issue:

https://www.youtube.com/watch?v=tHfkUrAWvnU

Device: Flame 2.5
BuildID: 20150817061040
Gaia: 60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gecko: a6eeb28458fd2652e12e57334f046b7776d75bb4
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Aries 2.5
BuildID: 20150817141354
Gaia: 60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gecko: a6eeb28458fd2652e12e57334f046b7776d75bb4
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

------

This issue does NOT occur on Flame 2.2. Following STR, the OK button on upper right stays intact as characters are being typed within SSID Network Name field.

Device: Flame 2.2
BuildID: 20150817032503
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: 82ec88fa015c
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

----

Since this is blocked on 2.5 I'm adding window wanted and I'll be working on getting the window.
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Keywords: qawanted → regressionwindow-wanted
QA Contact: pcheng
No longer working on this window.
QA Contact: pcheng
Flags: needinfo?(jmercado)
(Assignee)

Updated

3 years ago
Assignee: nobody → evan
Created attachment 8649724 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master
(Assignee)

Comment 9

3 years ago
Added patch[1], and continue to add tests.

[1]: https://github.com/evanxd/gaia/commit/36104bf3741be578d0de9d20661d6c32c0618036
(Assignee)

Comment 10

3 years ago
Comment on attachment 8649724 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master

Hi Fred,

Could you give feedback for the patch/

Thanks.
Attachment #8649724 - Flags: feedback?(gasolin)
Removing the regression window tag since the cause has already been identified and a patch has been made.  If a window is required at a later time please add the tag again.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 12

3 years ago
Comment on attachment 8649724 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master

thanks evan, due to I'm not familiar with the wifi part, 
Once the PR is ready, please add evelyn in review loop as well.
Attachment #8649724 - Flags: feedback?(gasolin) → feedback+
(Assignee)

Comment 13

3 years ago
Comment on attachment 8649724 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master

Hi Evelyn,

How do you think about the patch?
If everything is good, I'll add tests.

Thanks.
Attachment #8649724 - Flags: feedback+ → feedback?(ehung)

Comment 14

3 years ago
Comment on attachment 8649724 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master

The patch works but I'm quite understand the way you resolve the problem. Could you explain a bit? What's the root cause and what do you intend to do? Thanks.
Attachment #8649724 - Flags: feedback?(ehung) → feedback+
(Assignee)

Comment 15

3 years ago
Updated patch[1]: add reusable method `isSSIDValid` in `WifiHelper`. Continue to figure out how to write tests for the patch.

[1]: https://github.com/evanxd/gaia/commit/a37a7cb57f9fb4135edfa9f5e5e7640364812eb2
(Assignee)

Comment 16

3 years ago
(In reply to Evelyn Hung [:evelyn] from comment #14)
> Comment on attachment 8649724 [details] [review]
> [gaia] evanxd:bug-1170236 > mozilla-b2g:master
> 
> The patch works but I'm quite understand the way you resolve the problem.
> Could you explain a bit? What's the root cause and what do you intend to do?
> Thanks.

The root cause is that the `key` value from `var key = WifiHelper.getKeyManagement(network);` is always the same even user changed the "Security" type in "Authentication" page.

For example, if user change "Security" type as "WPA-PSK" then the key value should be "WPA-PSK" and so on. Should not be always the same. But the code in[1] just keeps the `key` value always as same value.

[1]: https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/modules/wifi_utils.js#L167
Please continue to work on this if you are almost done.  Setting a P2 priority for 2.5
Priority: -- → P2
(Assignee)

Comment 18

3 years ago
Sure, I'm writing marionette tests. Bug I cannot run tests in local. Investigate...
(Assignee)

Comment 19

3 years ago
Finally, can run marionette in local. But we cannot write marionette tests for Wi-Fi panel because `navigator.mozWifiManager` is undefined in B2G desktop client.
(Assignee)

Comment 20

3 years ago
Comment on attachment 8649724 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master

Hi Evelyn,

Could you review the patch?

The root cause is described in Comment 16.

Thanks.
Attachment #8649724 - Flags: review?(ehung)

Comment 21

3 years ago
Comment on attachment 8649724 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master

Sorry for my late response, but I have to redirect the review to Fred since I'm quite busy now and I believe Fred could do a better review than I do.
Fred, thank you.
Attachment #8649724 - Flags: review?(ehung) → review?(gasolin)

Comment 22

3 years ago
Comment on attachment 8649724 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master

Looks good with 1 place need to be addressed.
Attachment #8649724 - Flags: review?(gasolin) → review+
(Assignee)

Comment 23

3 years ago
Thanks for the review, Evelyn and Fred.

Updated patch for the comments: https://github.com/evanxd/gaia/commit/cccab77cc47bd4a7ce2df0e48dcb03ffb0c5a524
(Assignee)

Comment 25

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/a13057e1fbdc7e2b0f0f2469d6f22676239ba24d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Depends on: 1211976
The changes for this issue has caused a smoketest blocker bug 1211976.  Please backout if possible.
Whiteboard: [backout-asap]
master revert: https://github.com/mozilla-b2g/gaia/commit/0e82f063dec7992dcd25ca4fe42f6b06513b46ad
Status: RESOLVED → REOPENED
Flags: needinfo?(evan)
Resolution: FIXED → ---
Whiteboard: [backout-asap]
(Assignee)

Comment 28

3 years ago
Thanks for Tim's help.

Found out the root cause of Bug 1211976.

The `ssid`[1] is always `null` when user is in wifi panel. Then the submit button will be always disabled.

Continue to update the patch to fix it.

[1]: https://github.com/evanxd/gaia/commit/cccab77cc47bd4a7ce2df0e48dcb03ffb0c5a524#diff-34794e0518aee03061d801635e462145R202
Flags: needinfo?(evan)
Created attachment 8671147 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master
(Assignee)

Comment 30

3 years ago
Comment on attachment 8671147 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master

Hi Fred,

I updated patch to fix Bug 1211976.
Could you review it?

Thanks.
Attachment #8671147 - Flags: review?(gasolin)

Comment 31

3 years ago
Comment on attachment 8671147 [details] [review]
[gaia] evanxd:bug-1170236 > mozilla-b2g:master

test fine on device. 

We really need some unit test coverage here...
Attachment #8671147 - Flags: review?(gasolin) → review+
(Assignee)

Comment 32

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/ab08c32e8bd96c1fa1c8041f711ba9b14174750b
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Comment hidden (obsolete)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: affected → verified
Status: RESOLVED → VERIFIED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK v2.5 by the STR in comment 0 or comment 6 .

Actual results: When user enters a network name in the text box, the OK button at the top-right of the screen will be highlighted.
See attachment: Flame kk v2.5.3GP
Reproduce rate: 0/10


Device: FlameKK v2.5 (Pass)
Build ID               20151015150343
Gaia Revision          8ea9029190af2ffeb04dcd97b323738125e31a0e
Gaia Date              2015-10-15 14:30:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d374d16cbb251c9dac5af69f8e186e821ce82fe2
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151015.183044
Firmware Date          Thu Oct 15 18:30:54 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (Pass)
Build ID               20151015193337
Gaia Revision          8ea9029190af2ffeb04dcd97b323738125e31a0e
Gaia Date              2015-10-15 14:30:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d374d16cbb251c9dac5af69f8e186e821ce82fe2
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151015.185317
Firmware Date          Thu Oct 15 18:53:25 UTC 2015
Bootloader             s1
You need to log in before you can comment on or make changes to this bug.