Dismissing tabs requires too much gesture movement

RESOLVED FIXED

Status

()

Firefox for iOS
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: sleroux, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fennec+, fxios+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
From John Gruen:

Here’s a little usability hiccup:

It’s really hard to swipe-dismiss a tab toward the closer edge of the window in the new two-column tab page.* Would it be possible to make the swipe-dismiss gesture a little more sensitive?
----

Solution would be configure the swipe threshold parameters depending on the tab layout so it's easier to swipe for smaller tabs.
(Reporter)

Updated

3 years ago
tracking-fennec: --- → ?
tracking-fxios: --- → ?
Duplicate of this bug: 1169447
tracking-fennec: ? → +
tracking-fxios: ? → +
(Reporter)

Comment 3

3 years ago
Created attachment 8614854 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/555

Reduced it by 20px so now the user needs to pull 60px in either direction to delete the tab. Thoughts?
Attachment #8614854 - Flags: feedback?(dhenein)
Comment on attachment 8614854 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/555

This feels much better, feedback from some colleagues was positive as well. Lets land it and see if it addresses the issue people had.
Attachment #8614854 - Flags: feedback?(dhenein) → feedback+
(Reporter)

Comment 5

3 years ago
Merged.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.