Firefox installer could add the shortcut to the users desktop directory so it displays before all user desktop shortcuts though other users wouldn't automatically get a desktop shortcut then

RESOLVED WONTFIX

Status

()

Firefox
Installer
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox41 affected)

Details

(Reporter)

Description

3 years ago
While setting up a new Surface Pro, in installed (in order) Nightly, Canary, and Chrome. I was surprised to see that the order of the icons on my desktop (from top to bottom) is Chrome, Nightly, Canary.

Apparently when Chrome installs, it places its desktop shortcut at the top. (Just below the Recycle Bin, actually.) We might want to consider doing the same.
Canary is not placing its shortcut at the top... Windows is. Canary installs into an insecure location in your Windows profile directory and adds the desktop shortcut only for that user in the user's desktop directory. These shortcuts are sorted before the shortcuts in the all users desktop directory on the combined desktop.

If we were to add the shortcut to the user's desktop directory then secondary users wouldn't automatically get a desktop shortcut and likely wouldn't even know that Firefox was available to them. We could install into the insecure location as Canary does (we do for the user doesn't have write access case e.g. library kiosk, etc.) but then that install wouldn't be available to secondary users and we wouldn't be able to set up shell integration properly in that secondary users would see the option in Windows programs and features but they wouldn't be able to use it because the install would be in the other user's profile.

Personally, I think this is wontfix unless product drivers want to change the install to be like Canary's in that we always install into the profile without an option to install anywhere else.
Summary: Firefox installer could place the desktop shortcut more prominently → Firefox installer could add the shortcut to the users desktop directory though other users wouldn't automatically get a desktop shortcut then
Summary: Firefox installer could add the shortcut to the users desktop directory though other users wouldn't automatically get a desktop shortcut then → Firefox installer could add the shortcut to the users desktop directory so it displays before all user desktop shortcuts though other users wouldn't automatically get a desktop shortcut then
Side note: during the win2k joint deployment program I had a network device manufacturer as a client that wanted to have the desktop shortcuts in a specific order. The only way that was found to accomplish this was to create the first shortcut, refresh icons, create the shortcut shortcut, refresh icons, etc. and this all had to be done on a fresh desktop.
dolske, do you want to bring this up with product drivers or wontfix it or something else?
Flags: needinfo?(dolske)
(Reporter)

Comment 4

3 years ago
To be clear: it was the _Chrome_ icon that was inserted at the top, the _Canary_ icon was placed as I expected (below already installed shortcuts). I was a little surprised the two behaved differently.

Sounds like this implies that if other (existing) apps were installed in the same way as Chrome, they would show up before Chrome, and so this isn't actually about "Chrome puts itself on top"?

If this is just an unfortunate side-effect of system-vs-user install scope, I don't think we need to do anything. Mostly filed this to see if Chrome was doing something to explicitly change where its icon went, and if we should do the same.
Flags: needinfo?(dolske)
(In reply to Justin Dolske [:Dolske] from comment #4)
> To be clear: it was the _Chrome_ icon that was inserted at the top, the
> _Canary_ icon was placed as I expected (below already installed shortcuts).
> I was a little surprised the two behaved differently.
Sure. The positioning is also controlled by sorting which I believe is on by default on Windows and Windows often gets confused where I have to resort.

> Sounds like this implies that if other (existing) apps were installed in the
> same way as Chrome, they would show up before Chrome, and so this isn't
> actually about "Chrome puts itself on top"?
Yes

> If this is just an unfortunate side-effect of system-vs-user install scope,
> I don't think we need to do anything. Mostly filed this to see if Chrome was
> doing something to explicitly change where its icon went, and if we should
> do the same.
Quite certain they are not.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
BTW: the sorting isn't just by name. iirc first are system shortcuts (e.g. trash, my computer, etc.), shortcuts, directories, then files.
Duplicate of this bug: 1175548
You need to log in before you can comment on or make changes to this bug.