Closed Bug 11704 Opened 21 years ago Closed 21 years ago

Scriptable interface for international nsLocale does not work

Categories

(Core :: Internationalization, defect, P2)

All
Windows NT
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: teruko, Assigned: tague)

References

()

Details

Scriptable interface for international nsLocale does not work.

Steps of reproduce
1. Go to above URL
2. Click on Get Application Locale and Get System Locale buttons.
Nothing changed.

Since I was using Winnt 4.0J, the buttons should be changed to ja_JP.

I tested this in 8-11-09 Win32 and Mac builds.
This worked in 8-10-09 Win32 and Mac builds.
Priority: P3 → P2
Target Milestone: M9
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
the xpconnected interface is working fine.  take a look at my updated script
(http://warp/employees/tague/tests/nsLocaleTest.html), watch the console window
for the results from the locale interface.

the locale routines are returning the correct strings, but the buttons aren't
being updated.  i filed a new bug (#11723) to capture the button problem.
Status: RESOLVED → VERIFIED
OK. It works.
You need to log in before you can comment on or make changes to this bug.