[Calendar] fix remain jsdoc error

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: gasolin, Assigned: me, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: good-first-bug, zh)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Since bug 1151765 has landed and support es6 syntax for jsdoc parsing, there're still some syntax issues not resolved in gaia.

We could solve jsdoc issues per-app.
(Assignee)

Comment 1

3 years ago
I would like to work on it, can you assigned me on it ?
(Reporter)

Comment 2

3 years ago
Thanks for interesting in solving this issue.

First you need run `npm install` in gaia repo to get up-to-date packages. 

Then run command

`gulp jsdoc:calendar` to make sure everything works.

You can remove exclude files from jsdoc.json, fix the file and run the command again to check if jsdoc is actually fixed.
Assignee: nobody → me
Status: NEW → ASSIGNED
(Assignee)

Comment 3

3 years ago
Created attachment 8625857 [details]
List of the warning from JSDoc output on calendar

OK, i succeed to launch JSDoc on calendar, all of the warnings comes from non-support ES6 in JSDoc.

Do you have an idea how i can manage these warnings ?
Flags: needinfo?(gasolin)
(Reporter)

Comment 4

3 years ago
Warning is not relevant. 

Please try to remove exclude files from calendar's jsdoc.json, and see if any error showed in console log.
Flags: needinfo?(gasolin)
(Assignee)

Comment 5

3 years ago
Created attachment 8626207 [details] [review]
PR, review

 Bug 1170456 - [Calendar] fix remain jsdoc error #30710
"https://github.com/mozilla-b2g/gaia/pull/30710"
Attachment #8626207 - Flags: review?(gasolin)
(Reporter)

Comment 6

3 years ago
Comment on attachment 8626207 [details] [review]
PR, review

Thanks for provide fixes, the jsdoc fix part looks good to me.

Regarding the maintenance part, Please use rebase instead of merge so there's no extra merge log in gaia tree. And please squash your PR to single commit.

After fixing the issue, you could request review with gaye@mozilla.com who is the module owner of calendar app.
https://wiki.mozilla.org/Modules/FirefoxOS
Attachment #8626207 - Flags: review?(gasolin)
(Assignee)

Comment 7

3 years ago
Created attachment 8626599 [details] [review]
Bug 1170456 - [Calendar] fix remain jsdoc error R=romainloisel #30724

Bug 1170456 - [Calendar] fix remain jsdoc error R=romainloisel #30724 
"https://github.com/mozilla-b2g/gaia/pull/30724"
Attachment #8626599 - Flags: review?(gaye)
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1170453
(Assignee)

Comment 9

3 years ago
Gaye, could you review my PR ?
(Reporter)

Comment 10

3 years ago
Comment on attachment 8626599 [details] [review]
Bug 1170456 - [Calendar] fix remain jsdoc error R=romainloisel #30724

gaye is now out of office, transfer the review to Miller.
Attachment #8626599 - Flags: review?(gaye) → review?(mmedeiros)
Comment on attachment 8626599 [details] [review]
Bug 1170456 - [Calendar] fix remain jsdoc error R=romainloisel #30724

landed on master, sorry for the huge delay on the review: https://github.com/mozilla-b2g/gaia/commit/6dfeea505ce6efb3d139402c33b0695e247df9b6
Attachment #8626599 - Flags: review?(mmedeiros) → review+
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.