Bookmark- and Folder-Properties dialog box has grown to 4 times the width of my screen

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: David A. Cobb, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150601030203

Steps to reproduce:

This problem seems to have developed over time.  I do frequently need to zoom-in to read text correctly -- that may have triggered this symptom.
If I try "Add Folder" to my bookmarks tree, or if I select "Properties" either for a folder or for a bookmark, the resulting dialog box is now so wide I need to move it -- a lot!  It is now so wide that I can't tell when I'm moving it because all the features except the horizontal lines are off screen.



Expected results:

No dialog should be larger than the display.

Comment 1

3 years ago
Can you reproduce this in a brand new profile?
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles

If not, one of your add-ons may be to blame.
https://support.mozilla.org/kb/troubleshoot-extensions-themes-to-fix-problems
Component: Untriaged → Bookmarks & History
(Reporter)

Comment 2

3 years ago
Yes, a virgin profile did the trick.  I did have to jump through a few hoops to restore my bookmarks.  The Restore operation complained about the JSON file, but doesn't give a clue about what was / was not restored :-(( My bookmark collection is simply huge, losing it would have been horrible.  I also copied the *.db files which, ISTR, contain the security information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

3 years ago
RE-OPEN.
Today, the symptom is back again.  I haven't added any extensions since it was gone.  What I did do was open a LOT of tabs on about four windows.  I rather suspect some buffer-overflow polluting some critical data.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

3 years ago
I think I've identified a sequence of actions that trigger this, but I need someone to test it.
IN A VIRGIN PROFILE: Display a bookmark "Properties", verify that the dimensions of the dialog are correct.
1. Bring up the "Display all Bookmarks" Library panel.
2. Stretch the Library dialog, say to screen width.  Maybe do something in the Library panel.  Close it.
3. Bow bring back a bookmark Properties dialog.

Observe whether the dimensions of the Properties box have been changed.

Comment 5

3 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0
20150615030204

No problem with these STR:
1. Click the Bookmarks toolbar button.
2. Right-click a bookmark and choose Properties.
3. Click Cancel.
4. Ctrl+Shift+B.
5. Resize the Library window close to maximum screen size, without actually maximizing the window.
6. Close the Library window by clicking the X button.
7. Click the Bookmarks toolbar button.
8. Right-click a bookmark and choose Properties.
(Reporter)

Comment 6

3 years ago
(In reply to Gingerbread Man from comment #5)
Thank you, Gingerbread Man.  Damn! I thought I had found something.  At least, I think I can keep if from getting completely out of control.
(Reporter)

Comment 7

3 years ago
After months of NOT seeing this in Firefox Developer Addition (Aurora), suddenly it's BACK!
It's a huge reach that I can't really figure out, the one change in Aurora that stands out is that NoScript extension is now working with e10s.  When using Nightly or Release, I've always had NoScript on even if I needed to turn e10s off.  
Please suggest how I might test this or, at least, acquire more useful information.
(Reporter)

Comment 8

3 years ago
Just to confuse things further, in 43.0a1 (2015-09-09) this is NOT observed, as of today at least.
There may be a relation with bug 1199496? but that is an increase that grows over time...
Alternatively it may be a corruption of xulstore (ex localstore)
I think this may be fixed, if you can reproduce again feel free to reopen
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.