[PP] Various menu-related crashes

VERIFIED FIXED

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
19 years ago
a year ago

People

(Reporter: Simon Fraser, Assigned: saari (gone))

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I've seen various crashes today when clicking around in the menu bar. Here's
the stack trace for one of them. Sorry, I don't have good steps to reproduce.

 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  060A7FAD    PPC  0048535C  EmToNatEndMoveParams+00014
  060A7F40    PPC  00832660  MyMenuSelect+000F8
  060A7D20    68K  006C026C  MENUSELECTPATCH+00012
  060A7D0C    68K  006C0332  MenuSelectPatchMain+0002A
  060A7CD5    PPC  0048535C  EmToNatEndMoveParams+00014
  060A7C80    PPC  18530C58  GetSubmenuParentChoosable+0016C
  060A7C30    PPC  18531454  GetSubmenuParentChoosable+00968
  060A7B90    PPC  185310FC  GetSubmenuParentChoosable+00610
  060A7AF0    PPC  18531888  GetSubmenuParentChoosable+00D9C
  060A7AB0    PPC  18531DEC  GetSubmenuParentChoosable+01300
  060A7A60    PPC  1852A85C  CallMenuBar+00134
  060A796A    68K  00AA80B8
  060A791B    PPC  0048535C  EmToNatEndMoveParams+00014
  060A78C0    PPC  00B54228  'MBDF 003F 0002'+00148
  060A7880    PPC  18535AB0  StandardMBDF+001E0
  060A77B0    PPC  185386E4  StandardMBDF+02E14
  060A7760    PPC  FFD1B578  CalcMenuSize+0001C
  060A7643    PPC  0048535C  EmToNatEndMoveParams+00014
  060A75C0    PPC  16A07380  nsDynamicMDEFMain+00090
  060A7570    PPC  16A074D0  nsCheckDestroy(MenuInfo**, short*)+000A0
  060A7520    PPC  16A0806C  nsPreviousMenuStackUnwind(nsIMenu*, MenuInfo**)+
00144
  060A7480    PPC  169DD328  nsMenu::MenuDeselected(const nsMenuEvent&)+00034
  060A7440    PPC  169DDD60  nsMenu::MenuDestruct(const nsMenuEvent&)+000C0
 Closing log

Comment 1

19 years ago
I've also had a menu crash (and corruption) on Mac OS. Using today's build, I've

seen the bottom two items on the File menu become filled with garbage (sorry,

don't remember specific content), and drawn in Bold Outline.



Upon trying to re-open the menu a second time, Communicator froze for a bit, and

then crash, without displaying any File menu content. (Tracking ID HLP33TKA)



The how/sc was:



PowerPC unmapped memory exception at 0E0AAAE4 BowelsOfTheMemoryMgr+091A4



 Calling chain using A6/R1 links

  Back chain  ISA  Caller

  059BFE05    PPC  0020964C  EmToNatEndMoveParams+00014

  059BFD80    PPC  00565D18

  059BFD30    PPC  0E0A108C  __SetHandleSize+00014

  059BFCF0    PPC  0E0A3140  BowelsOfTheMemoryMgr+01800

Updated

19 years ago
Summary: Various menu-related crashes → [PP] Various menu-related crashes

Comment 2

19 years ago
(Adding [PP] for Platform Parity, since I believe this is Mac OS-only.)

Comment 3

19 years ago
I've now also encountered Simon's crash. (no menu bar corruption, just a freeze
and then a crash.)

Chris, unfortunately, I haven't been able to come up with a test case for either.
I do note that the bold, outline content on the bottom two items of the File menu
that occured prior to this crash was the content of the Apple menu, in case that
gives a hint.

See ya.
(Reporter)

Comment 4

19 years ago
I have a reproducible case, though I suspect that the real cause of the crash is
that something is being leaked. Anyway, try this:

In apprunner, load http://jazz/users/sfraser/publish.
File->Edit page.
Then in the editor window, Format->Apply Style Sheet.
Now close the editor window, to return to the browser window (and its menu bar).
Now click on the menu bar. You will crash.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
This was an XP bug, hyatt found the same thing on XPMenus. When doing
RemoveAttribute after closing a window, RDF crashed because the domDoc was null.
The solution is to check the domDoc status before calling RemoveAttribute. hyatt
did the same thing in XPMenus.

Comment 6

19 years ago
Sorry for spam, re-assigning phillip's QA contact XPToolkit/XPWidget bugs to
claudius due to restructure

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
VERIFIED fixed for 1999101308 builds.
You need to log in before you can comment on or make changes to this bug.