Allow fetch inspected object in console DevTool

RESOLVED DUPLICATE of bug 1025778

Status

()

Firefox
Developer Tools: Console
RESOLVED DUPLICATE of bug 1025778
2 years ago
2 years ago

People

(Reporter: merzhin, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150515073613

Steps to reproduce:

Open Devtool, go to Console
type:
inspect({prop: 'hello', world: 12})


Actual results:

the Inspect Panel show the object; 
but you have no way of assigning the object as a Js variable



Expected results:

the Inspect Panel show the object; 
but if you type a command like $_ or smthing similar, 
you can assign it to a var.

example

var myInspectedObject = $*
==> assign the inspected object to "myInspectedObject"

Updated

2 years ago
Component: Untriaged → Developer Tools: Console
Hi, we have a similar feature planned where you can assign the variable from console output
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1025778
You need to log in before you can comment on or make changes to this bug.