URL bar goes away when theme is changed dynamically

VERIFIED DUPLICATE of bug 115919

Status

Core Graveyard
Skinability
VERIFIED DUPLICATE of bug 115919
16 years ago
9 years ago

People

(Reporter: Dan Tobias, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I can't quite figure out how to reproduce this, but it's happened a couple of
times already.  (I'm using build 2001122603.)  The URL bar blanks out completely
and doesn't take any input, and the "down-arrow" icon for the pulldown list of
URLs shows just right of the icon with no place for typing a URL.  A large blank
space shows to the right of the pulldown, going further out than the URL bar
usually goes, pushing the other buttons to the right of it off the screen.  I'll
attach a screenshot to show what I'm talking about.  The pulldown menu still
works, but you can't type a URL.
(Reporter)

Comment 1

16 years ago
Created attachment 62849 [details]
Screenshot of browser with this problem
(Reporter)

Comment 2

16 years ago
OK... I think I've figured out how to reproduce it now... all you have to do is
change themes (View: Apply Theme), and it triggers this bug.
Summary: URL bar goes away → URL bar goes away when theme is changed dynamically
To skinability
Assignee: hewitt → ben
Component: URL Bar → Skinability
QA Contact: claudius → pmac
(Reporter)

Comment 4

16 years ago
It just happened to me again, and this time I hadn't changed themes, so there
must be other circumstances when this bug is triggered.  I'm not positive
exactly what happened this time to bring it on.

Comment 5

16 years ago
It happens every time for me if I leave only a download window open (closing all
other browser windows) and then click on the mozilla icon on my desktop to spawn
a new browser window. This is using trunk build 20011226 on Win98SE

Comment 6

16 years ago
HOwever, it doesn't seem to occur using the method described in my previous
comment with 20011227 trunk build, Win98SE
*** Bug 117261 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Reporter,
  Could you please try creating and using a new profile?  (On a more recent
build)  Run "mozilla -profilemanager" to do this.  If you have any problems
creating a new profile, join us on irc.mozilla.org in #mozillazine and we'll be
glad to help you.

Thanks.
(Reporter)

Comment 9

16 years ago
It doesn't seem to be doing this bug now for me, in build 2002011103, even
though I haven't created a new profile as asked.  However, I'm at home now and I
think I was at work when I observed the bug earlier, so I'll try it there tomorrow.
(Reporter)

Comment 10

16 years ago
I tried changing themes on my system at work where I first observed this bug.

The first time I changed from Modern to Classic, the browser crashed.

After restarting, I was able to change between the two themes with no further
crashes, and without triggering this bug.  However, there was a minor glitch on
changing to Modern, in which the cursor doesn't show when you focus on the URL
bar (though you can still type in it).  This goes away as soon as you load
another page.

Comment 11

16 years ago
Dan, I could reproduce the crash while switching themes in preferences dialog, 
not go to View > Apply Theme...

Here is the stack trace on windows 98 (commercial build: 2002-01-17-09-trunk).
Stack Trace
nsLineLayout::IsPercentageUnitSides 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 1767]
IsPercentageAwareChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1138]
nsBlockFrame::ReflowInlineFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3727]
nsBlockFrame::DoReflowInlineFrames 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3616]
nsBlockFrame::DoReflowInlineFramesAuto 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3541]
nsBlockFrame::ReflowInlineFrames 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3486]
nsBlockFrame::ReflowLine 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2601]
nsBlockFrame::ReflowDirtyLines 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2279]
nsBlockFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 846]
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
771]
nsTableCellFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableCellFrame.cpp, line 
943]
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
771]
nsTableRowFrame::ReflowChildren 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 
1039]
nsTableRowFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 
1427]
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
771]
nsTableRowGroupFrame::ReflowChildren 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 453]
nsTableRowGroupFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 1155]
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
771]
nsTableFrame::ReflowChildren 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 3137]
nsTableFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 1934]
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
771]
nsTableOuterFrame::OuterReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
979]
nsTableOuterFrame::IR_InnerTableReflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
1296]
nsTableOuterFrame::IR_TargetIsMe 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
1245]
nsTableOuterFrame::IncrementalReflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
1029]
nsTableOuterFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
1531]
nsBlockReflowContext::DoReflowBlock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, 
line 581]
nsBlockReflowContext::ReflowBlock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, 
line 359]
nsBlockFrame::ReflowBlockFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3230]
nsBlockFrame::ReflowLine 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2506]
nsBlockFrame::ReflowDirtyLines 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2279]
nsBlockFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 846]
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
771]
nsTableCellFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableCellFrame.cpp, line 
943]
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
771]
nsTableRowFrame::IR_TargetIsChild 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 
1261]
nsTableRowFrame::IncrementalReflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 
1156]
nsTableRowFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 
1431]
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
771]
nsTableRowGroupFrame::IR_TargetIsChild 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 1555]
nsTableRowGroupFrame::IncrementalReflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 1232]
nsTableRowGroupFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 1142]
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
771]
nsTableFrame::IR_TargetIsChild 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2856]
nsTableFrame::IncrementalReflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2695]
nsTableFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 1950]
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
771]
nsTableOuterFrame::OuterReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
979]
nsTableOuterFrame::IR_InnerTableReflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
1296]
nsTableOuterFrame::IR_TargetIsInnerTableFrame 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
1085]
nsTableOuterFrame::IR_TargetIsChild 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
1075]
nsTableOuterFrame::IncrementalReflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
1038]
nsTableOuterFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
1531]
nsBlockReflowContext::DoReflowBlock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, 
line 581]
nsBlockReflowContext::ReflowBlock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, 
line 359]
nsBlockFrame::ReflowBlockFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3230]
nsBlockFrame::ReflowLine 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2506]
nsBlockFrame::ReflowDirtyLines 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2279]
nsBlockFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 846]
nsBlockReflowContext::DoReflowBlock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, 
line 581]
nsBlockReflowContext::ReflowBlock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, 
line 359]
nsBlockFrame::ReflowBlockFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3230]
nsBlockFrame::ReflowLine 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2506]
nsBlockFrame::ReflowDirtyLines 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2279]

Comment 12

16 years ago

*** This bug has been marked as a duplicate of 115919 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 13

16 years ago
Verified dup of 115919.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.