[Aries][Settings][Cellular & Data] The user can enable Data Roaming without enabling Data Connection when the device does not have a SIM

RESOLVED DUPLICATE of bug 1170820

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1170820
3 years ago
3 years ago

People

(Reporter: Marty, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8614394 [details]
logcat-aries-sim-data.txt

Description:
If the user does not have a SIM Card in their device, and they navigate to Settings > Cellular & Data, they are able to activate Data Roaming without first activating Data Connection.

Note: Data Roaming does not remain enabled after inserting a SIM card and rebooting the device.

Repro Steps:
1) Update a Xperia Z3 Compact (B2G) to 20150602115822
2) Ensure there is not a SIM card in the device.
3) Launch the Settings app and navigate to Cellular & Data
4) Toggle Data Roaming on without activating Data Connection.

Actual:
Data Roaming can be enabled without enabling Data Connection

Expected:
Data Roaming is greyed out, and cannot be enabled before first enabling Data Connection.

Environmental Variables:
Device: Xperia Z3 Compact (B2G) 3.0 (Full Flash)
Build ID: 20150602115822
Gaia: Unknown
Gecko: 9eae3880b132
Version: 41.0a1 (3.0)
User Agent: 

Repro frequency: 5/5
See attached: Logcat, Video (URL)
(Reporter)

Comment 1

3 years ago
This issue does NOT occur on Flame 3.0 builds.
On a device without a SIM Card, Data Roaming is greyed out, and cannot be enabled before first enabling Data Connection.

Environmental Variables:
Device: Flame 3.0 (Full Flash)
Build ID: 20150602055237
Gaia: 6d477a7884273886605049b20f60af5c1583a150
Gecko: 9eae3880b132
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
functional regression from flame behavior.
blocking-b2g: --- → spark?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Status: NEW → RESOLVED
blocking-b2g: spark? → ---
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1170820
You need to log in before you can comment on or make changes to this bug.