Closed Bug 1170849 Opened 6 years ago Closed 6 years ago

WebGL 2 - Rendering to MRT failures

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: u480271, Unassigned)

References

()

Details

(Whiteboard: [gfx-noted])

test that gl_FragColor only writes to color number zero
PASS attachment 0 should be 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255

test that an OpenGL ES Shading Language 3.00 shader with a single output color only writes to color number zero
PASS attachment 0 should be 255,0,0,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 0,255,0,255 was 0,0,255,255

test setting first half to NONE and clearing
PASS attachment 0 should be 255,0,0,255
FAIL at (0, 0) expected: 255,0,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 255,0,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 255,0,0,255 was 0,0,255,255
PASS attachment 4 [details] [diff] [review] should be 0,255,0,255
PASS attachment 5 [details] should be 0,255,0,255
PASS attachment 6 [details] should be 0,255,0,255
PASS attachment 7 [details] should be 0,255,0,255

test setting first half to NONE and drawing
PASS attachment 0 should be 255,0,0,255
FAIL at (0, 0) expected: 255,0,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 255,0,0,255 was 0,0,255,255
FAIL at (0, 0) expected: 255,0,0,255 was 0,0,255,255
PASS attachment 4 [details] [diff] [review] should be 255,0,255,0
PASS attachment 5 [details] should be 0,255,255,0
PASS attachment 6 [details] should be 255,255,255,0
PASS attachment 7 [details] should be 0,0,0,255

check framebuffer with all attachments off
PASS gl.getParameter(gl.DRAW_BUFFER0 + 0) is gl.NONE
PASS gl.getParameter(gl.DRAW_BUFFER0 + 1) is gl.NONE
PASS gl.getParameter(gl.DRAW_BUFFER0 + 2) is gl.NONE
PASS gl.getParameter(gl.DRAW_BUFFER0 + 3) is gl.NONE
PASS gl.getParameter(gl.DRAW_BUFFER0 + 4) is gl.NONE
PASS gl.getParameter(gl.DRAW_BUFFER0 + 5) is gl.NONE
PASS gl.getParameter(gl.DRAW_BUFFER0 + 6) is gl.NONE
PASS gl.getParameter(gl.DRAW_BUFFER0 + 7) is gl.NONE
test attachment size mis-match
FAIL gl.checkFramebufferStatus(gl.FRAMEBUFFER) == gl.FRAMEBUFFER_COMPLETE should be true. Was false.
FAIL gl.checkFramebufferStatus(gl.FRAMEBUFFER) == gl.FRAMEBUFFER_COMPLETE should be true. Was false.

check that MAX_DRAW_BUFFERS and MAX_COLOR_ATTACHMENTS are the same
PASS gl.getParameter(gl.MAX_DRAW_BUFFERS) == gl.getParameter(gl.MAX_COLOR_ATTACHMENTS) is true
FAIL getError expected: NO_ERROR. Was INVALID_ENUM : there should be no errors
Assignee: nobody → ethlin
Some of this was fixed by the recent texture refactor, so pull a recent copy of central before starting on this.
There is some error messages about shader: "Error compiling VERTEX_SHADER '[object WebGLShader]':ERROR: 0:1: '' :  #version required and missing.". After applying the attachment 8693246 [details] [diff] [review] in bug1207288, the problem is fixed and the test is passed.
So I set dependency to bug1207288.
Assignee: ethlin → nobody
Depends on: 1207288
All tests passed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.