bluetoothd build error due to changed function signature

RESOLVED DUPLICATE of bug 1153155

Status

Firefox OS
Bluetooth
RESOLVED DUPLICATE of bug 1153155
3 years ago
3 years ago

People

(Reporter: tedd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
bluetoothd[1] fails to build on flame-l due to a changed function signature in libhardware[2] introduced in commit 091164c3296dd86de31933500c95df59dac6c230[3]

I am using the latest flame-l.xml[4] manifest.

[1] https://github.com/mozilla-b2g/platform_system_bluetoothd
[2] https://github.com/t2m-foxfone/android_platform_hardware_libhardware
[3] https://github.com/t2m-foxfone/android_platform_hardware_libhardware/commit/091164c3296dd86de31933500c95df59dac6c230
[4] https://github.com/viralwang/b2g-manifest/blob/flame-l/flame-l.xml

Comment 1

3 years ago
Hi Julian,

I think flame-l.xml should include gonk-patches.
There should be a patch[1] to fix the build error.

It will merge this patch after I fork libhardware to mozilla-b2g 

[1] https://github.com/viralwang/gonk-patches/blob/flame-l/all-flame/hardware/libhardware/0001-Revert-Bluetooth-SAP-Header-files-changes-to-support.patch
(Reporter)

Comment 2

3 years ago
Ok great, didn't see that there, will try rebuilding tomorrow. Sorry about the confusion.

Comment 3

3 years ago
I think it should be fine since it should patch automatically since the manifest[1] looks fine

Please let me know if it works for you, thanks :)

[1] https://github.com/viralwang/b2g-manifest/blob/flame-l/flame-l.xml#L45
Hi,

If there's an easy way of detecting and handling this difference in bluetoothd, I wouldn't mind adding a patch for it.

Comment 5

3 years ago
I already put the patch in the manifest, it will patch automatically when you run build.sh

Since t2m only provide CAF android, that's why we have to patch it to make it build pass.
Also, it won't be an issue after we fork from t2m to b2g, I will merge the necessary patch to b2g github.
(Reporter)

Comment 6

3 years ago
Ok, so I don't know exactly what I did for it to not automatically patch when running build.sh, but must have been some combination of me messing around with the code and repo sync -d. Anyway, I deleted out/lastpatch.md5sum and ran build.sh again and it applied the patch as intended.
Blocks: 1174670
No longer blocks: 1174670

Comment 7

3 years ago
I think this bug no longer exist since bug 1153155 already landed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1153155
You need to log in before you can comment on or make changes to this bug.