zh-TW of MDN/Mozilla/Add-ons site not found

RESOLVED FIXED

Status

P5
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: thomas, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

3 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

For "開始製作附加元件"(Start Making Add-ons) button in https://addons.mozilla.org/zh-TW/developers/ go to a "Not Found" page.
I think it's because the page have not been localized: https://developer.mozilla.org/zh-TW/Add-ons

solution: let's find someone translate the page :/

better solution: dev.m.o should redirect untranslated pages to English pages as a fallback.

Comment 2

3 years ago
l10ned ver of /Add-ons was located on https://developer.mozilla.org/zh-TW/docs/Mozilla/Add-ons
but it's broken also. 

(Open the page and shift-F5 to reload, you'll see "Internal Server Error")

Comment 3

3 years ago
(In reply to Irvin (MozTW) from comment #2)
> l10ned ver of /Add-ons was located on
> https://developer.mozilla.org/zh-TW/docs/Mozilla/Add-ons
> but it's broken also. 
If we could get it located back to 
https://developer.mozilla.org/zh-TW/Add-ons
It will be better (then we can start l10n /Mozilla for the right hierarchy)
Fixed. The zone was not created.

You'll need to translate the top-level page and its menu for the navigation to work.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 5

3 years ago
(In reply to Jean-Yves Perrier [:teoli] from comment #4)
> Fixed. The zone was not created.
> 
> You'll need to translate the top-level page and its menu for the navigation
> to work.

Hi :teoli,

IS there any docs regard of "top-level page and its menu"? 
or we should just finish the translate and the menu will appear at it's place as it should be?

Currently the menu had fallen down all the way to page bottom.
One rule the title of the menu must be SubNav.

Comment 7

3 years ago
Hi :teoli, 

There is some strange problem exist on this page,

1. There are some weird fluorescent color on the content
2. If we do a clean reload (shift-F5), it will showing a 404
3. Once we save the page after edit, it will showing 404 also (but however the edit will be saved)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
1. This has been added by this revision: https://developer.mozilla.org/zh-TW/Add-ons$compare?locale=zh-TW&to=813609&from=813603
Likely a cut & paste with inline CSS.

2 & 3 are likely regression due to the recent migration to Django 1.7. I'll open a new bug on Kuma.
Two more bits of info:

I have filed bug 1175044 for 2 & 3.

For 1: there are rogue spans in the page (you see them in source mode) removing them will clean the page.

Irvin: once cleaned, can you close the bug? Thanks.

Comment 10

3 years ago
my bad, didn't notice that span for diff color ^^;
thank for help!
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.