'clear your recent history' closes open tabs when done after browser restart

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: ssergeje1, Unassigned)

Tracking

40 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

1 Start Firefox dev edition
2 Open two tabs (eg google.com and mozilla.org)
3 Go to Preferences -> Privacy -> 'Clear your recent history'
4 Quit browser
5 Start Firefox dev edition again
6 Go to Preferences -> Privacy -> 'Clear your recent history'
expected: history cleared, tabs remain
actual: open tabs are closed

If after step 5 you open 3rd tab, eg yahoo.com and then proceed to clear history, two tabs from restored session will be closed. 3rd tab, yahoo.com in my example, will remain.

MacOS X 10.10.3
Firefox Dev Edition 40.0a2 (2015-06-02)
here is the video I made with those steps http://youtu.be/gMptm4m0J20

This started happening from June 2nd. I need to clean data due to working with web development and this hit me several times : (


Actual results:

history cleared AND open tabs are closed


Expected results:

history cleared, tabs remain open
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151208004011

Hi,

I tested this with latest Firefox Developers Edition 44.0a2, and I can't reproduce the problem. Please retest this issue with latest Firefox Developers Edition 44.0a2, download from here: https://www.mozilla.org/en-US/firefox/developer/#
Do you still have this problem?
Flags: needinfo?(ssergeje1)
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
(Reporter)

Comment 2

3 years ago
(In reply to ovidiu boca from comment #1)
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0)
> Gecko/20100101 Firefox/44.0
> Build ID: 20151208004011
> 
> Hi,
> 
> I tested this with latest Firefox Developers Edition 44.0a2, and I can't
> reproduce the problem. Please retest this issue with latest Firefox
> Developers Edition 44.0a2, download from here:
> https://www.mozilla.org/en-US/firefox/developer/#
> Do you still have this problem?

Hello. Indeed, this problem does not occur anymore. 
It seems I cannot close this ticket, so leaving it as is.

Cheers!
Based on comment 2, the status will be Resoled: WFM 
If you still have this issue please reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.