answering no to set moz as default browser affects link in email - opens blank ie window

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Heiko Adams, Assigned: Bill Law)

Tracking

({qawanted})

Trunk
x86
Windows 2000
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
After installing Mozilla and answering the question to make Mozilla to my
default application for the internet i was unable to use any links in Outlook
Express.
This means that an blank Internet Explorer opens instead of an Internet Explorer
who is opening the selected link. This problem is reproduceable since Mozilla
0.9.3 .

Comment 1

17 years ago
> This means that an blank Internet Explorer opens instead of an Internet Explorer
> who is opening the selected link. This problem is reproduceable since Mozilla
> 0.9.3 .

could you possibly clarify your statement?
do you mean,
"this means that a blank mozilla window opens instead of opening the selected link"?

Comment 2

17 years ago
> From: "Heiko Adams" <heiko_adams@web.de>
> Hi,
> no I realy mean a blank Internet Explorer window because the Internet Explorer
> is my default application for the internet.
> But i got this problem since i installed Mozilla.

ok, so are you saying you want mozilla to be your default internet application
for launching links from outlook express, instead of internet explorer.

or in other words.
that when mozilla asked you if you want to make it the default program, you
selected yes. but in reality, it didn't make it your default program?

Comment 3

17 years ago
stupid me, i'm confused. ;)

Comment 4

17 years ago
Heiko Adams, does Mozilla launch when you click on a link in outlook? What if
mozilla is already running, does it load the URL? 

(please reply in the bug report rather than by email. there is a link at the top
of this email notification)
Assignee: asa → pchen
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh

Comment 5

17 years ago
> From: "Heiko Adams" <heiko_adams@web.de>
> Hi,
> sorry, but you misunderstand me. the problem is:
> when mozilla asked me if i want to make it the default program, i
> selected no. and after that i got the discribed problem.

ok, so you mean that even though you didn't make mozilla your default browser,
this affected internet explorer. in the way that when you clicked on a link in
outlook, internet explorer started up, but didn't load the link?

Comment 6

17 years ago
> From: "Heiko Adams" <heiko_adams@web.de>
> yes you got it. that's the problem. the internet explorer didn't load the link.

heiko: as asa said, instead of replying by email to me, use the link at the top
of this email. and enter comments in the 'Additional Comments' box, then click
'Commit'.
(Reporter)

Comment 7

17 years ago
yes you got it. that's the problem. the internet explorer didn't load the link.

Comment 8

17 years ago
heiko: could you please check if bug 112616 is related,
since this may be a duplicate.
(Reporter)

Comment 9

17 years ago
The problem seems to be the same with the following difference:
- i didn't make mozilla to my default browser 
- i got the problem with the IE. 
trudelle to triage
Assignee: pchen → trudelle
Keywords: qawanted

Comment 11

17 years ago
->law.  can anyone confirm this?
Assignee: trudelle → law

Comment 12

17 years ago
wfm - 20020109, win95 installer-sea.

outlook used to launch links, worked fine, ie was the default browser. installed
moz, answered no to 'set as default'. launched the link from email, done fine
under ie4. afterwards, ran moz, - preferences - advanced - system, nothing was
selected.

of course, tested with new profile, and new reg entries.

heiko: which build were you using when this happened? can you reproduce the
problem using the latest nightly?
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/

not required, but changing summary, from
'Problems with links in Outlook Express after installting Mozilla'
to: "answering no to set moz as default browser affects link in email - opens
blank ie window"

shorten the summary if you want ;)
Summary: Problems with links in Outlook Express after installting Mozilla → answering no to set moz as default browser affects link in email - opens blank ie window
(Reporter)

Comment 13

17 years ago
I use the 0.9.7 milestone release and the IE 6. I'll download the latest build 
and tell you if the problem is still available ;-)
(Reporter)

Comment 14

17 years ago
The bugs seems to be fixed in the latest build (BuildID 2002011003). I've 
uninstalled Mozilla, deleted the Mozilla-directory, reinstalled mozilla, opened 
OE clicked on a link and the IE opened the link. :)
(Reporter)

Comment 15

17 years ago
Sorry, i forgot: i got the question to make mozilla to default browser and 
answered "no"
(Reporter)

Comment 16

17 years ago
I'm sorry, but after rebooting my system i determined that in the latest build
the bug is still there. :-(

Comment 17

16 years ago
I have also experienced this problem with Windows XP and Mozilla 0.9.8 and
0.9.9.  I did not select Mozilla as the default browser and now IE does not open
a new page properly (opens a blank IE) any more when I click on a link in my
email client (PC-Pine 4.4x).  Clinking on a web page link that opens a new IE
Window also exhibits the same behavior unless it's an aspx page.  It doesn't
matter if it's regular HTML code or javascript opening a new window.  Both have
the same result.

I went on MS site to look for help and found Q281679, which seemed to help (I
tried so many things I don't know what exactly fixed it) after I installed
0.9.8.  It hasn't helped with 0.9.9 because the settings were not incorrect
after installing 0.9.9.  I tried reinstalling MS' Java RE but that didn't help
the javascript.

I also uninstalled 0.9.8 before installing 0.9.9, although my profile still existed.

Comment 18

16 years ago
I can confirm this behaviour - I submitted Bug 132573 about it, having
apparently queried the wrong field. Still happening with 0.9.9 2002031104.

On Win2k Pro and WinMe with IE 5.01/5.5 SP2/6.0 as the default browser, Mozilla
will break the default browser setting. This happens if 'no' is selected when
asked to set Mozilla as the default browser, or when not asked at all because a
Mozilla was already installed. I have repeated personal experience of this
behaviour.

Comment 19

16 years ago
*** Bug 132573 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 20

16 years ago
Just a couple updates.  

1.  This bug also affects Windows Update's ability to update and show the 
appropriate patches.  I had to access the patches via the Windows Catalog 
section of Windows Update. ("corporate" downloading of patches)

2.  I reinstalled IE6 and manually re-installed the patches, which has fixed 
the problem.  I'm not sure which patch fixed the problem, since there are 20 
or so on the windowsupdate site.  I updated them through the Windows catalog 
section.

I'm pretty sure that reinstalling IE6 and rebooting didn't fix the problem 
alone, but that one or more of the patches fixed the problem in the end.

Comment 21

16 years ago
I've now done two installs of 1.0rc1; one over 0.9.9 on win2k, one over 0.9.9 
on winme, and then I uninstalled 1.0rc1 and re-installed it (so that I got 
the 'do you want mozilla to be the default browser' question, to which I 
answered no).

None of them seemed to damage the default browser setting (restarting IE after 
the install, with the browser check enabled, didn't flag a change, and clicking 
links in the shell starts IE normally) - this bug seems to have been fixed 
between 0.9.9 and 1.0rc1. Can anyone confirm this?

Comment 22

16 years ago
Er, make that /three/ installs.

Comment 23

16 years ago
So this bug, despite apparently being fixed - 1.0rc3 also didn't cause it - is 
going to be left open to rot then, is it?

Oh well. I'm sure someone will notice if I carry on poking at it, once a month.

Comment 24

16 years ago
Reporter: (Heiko Adams) have you been able to reproduce this using the latest
build? - moz rc3 ?

If not, please mark it as Fixed or WorksForMe.

Thanks.
(Reporter)

Comment 25

16 years ago
I'm unable to reproduce. So it seems to work.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.