After reboot most homescreen icons are very small

RESOLVED DUPLICATE of bug 1154055

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1154055
3 years ago
3 years ago

People

(Reporter: gerard, Unassigned)

Tracking

({dogfood, regression})

unspecified
ARM
Gonk (Firefox OS)
dogfood, regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
I don't know exactly why, but I saw my Gecko crashing/rebooting, and after that the homescreen icons were mostly very small.

Gecko 8e2e7660aed97a051dfbe03c0acaee26a8e45eba
Gaia 5ef5d283279c339b54a45c206e12b01ccb1c5b77
Android 5.1
(Reporter)

Comment 1

3 years ago
Created attachment 8614680 [details]
2015-06-03-16-20-54.png
No repro on 2.2 [1]. QAWanted for a branch check.

[Blocking Requested - why for this release]: Regression which may impact the first experience.

[1] Build ID               20150603002503
Gaia Revision          a9aeb08263f1a727136e8ae78425e52431c82770
Gaia Date              2015-06-02 13:04:40
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5b3f1796ddf6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150603.035922
Firmware Date          Wed Jun  3 03:59:33 EDT 2015
Bootloader             L1TC000118D0
blocking-b2g: --- → spark?
status-b2g-v2.2: --- → unaffected
Keywords: qawanted

Comment 3

3 years ago
This looks like the size of collapsed icons, but the group is obviously not collapsed - possibly an exception during render meant that it stopped half-way and the style on these icons wasn't reset - do the icons remain this way if you collapse/expand a group? Or if you reboot? Are there any exceptions in the console?
Flags: needinfo?(lissyx+mozillians)
(Reporter)

Comment 4

3 years ago
(In reply to Chris Lord [:cwiiis] from comment #3)
> This looks like the size of collapsed icons, but the group is obviously not
> collapsed - possibly an exception during render meant that it stopped
> half-way and the style on these icons wasn't reset - do the icons remain
> this way if you collapse/expand a group? Or if you reboot? Are there any
> exceptions in the console?

I have no logs, because I had to reboot the device. After a reboot it was not reproduced.
Flags: needinfo?(lissyx+mozillians)

Comment 5

3 years ago
If someone reproduces this, please capture the console of the homescreen and report on any exceptions. I expect this is an exception at some point during rendering and that having that exception would point us to exactly where our attention is needed.
Chris, can you take this please?
blocking-b2g: spark? → spark+
Flags: needinfo?(chrislord.net)
I can't reproduce on aries task cluster build.

Build ID               20150603204744
Gaia Revision          9e10483c5808f94f4a0a9f6afe30aae2c5b42b4c
Gaia Date              2015-06-03 19:22:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0920f2325a6d
Gecko Version          41.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150603.203317
Firmware Date          Wed Jun  3 20:33:25 UTC 2015
Bootloader             s1

How did you push the gaia?  did you use GAIA_DEV_PIXELS_PER_PX=2.25 in your make statement when you built?
Flags: needinfo?(lissyx+mozillians)
(Reporter)

Comment 8

3 years ago
That was the very same build as I always do, do yes, this was properly set. As I documented, I have no idea what happened, and how to reproduce.
Flags: needinfo?(lissyx+mozillians)
I was unable to reproduce this issue on a recent build.  Changing the flag to steps wanted since we'll need good steps before we can do valid branch checks.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150603191445
Gaia: 9e10483c5808f94f4a0a9f6afe30aae2c5b42b4c
Gecko: 98820360ab66
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Flags: needinfo?(ktucker)
Keywords: qawanted → steps-wanted
I was also unable to reproduce the issue. I think we first need to figure out how the reporter had their Gecko crashed at the first place, as according to the reporter the issue was only seen after the Gecko crash/reboot.

Tested on 3.0 on Flame and Aries.

Environmental Variables:
Device: Xperia Z3 Compact (B2G) 3.0
BuildID: 20150603204744
Gaia: 9e10483c5808f94f4a0a9f6afe30aae2c5b42b4c
Gecko: 0920f2325a6d
Version: 41.0a1 (3.0)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Device: Flame 3.0
BuildID: 20150604010200
Gaia: 9e10483c5808f94f4a0a9f6afe30aae2c5b42b4c
Gecko: 98820360ab66
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Leaving steps-wanted for others to attempt.
Flags: needinfo?(ktucker)
(In reply to Alexandre LISSY :gerard-majax from comment #0)
> Android 5.1

Maybe that's the issue?

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(chrislord.net)
Resolution: --- → DUPLICATE
Duplicate of bug: 1154055
Keywords: steps-wanted
(Reporter)

Comment 13

3 years ago
Fabrice just reproduced it next to me, after flashing a new Gecko.
If this is being reproduced and bug 1154055 is definitely applied to whatever Gaia is flashed, please attach either a logcat (with console output) or consistent STR.
blocking-b2g: spark+ → 2.5+
You need to log in before you can comment on or make changes to this bug.