The default bug view has changed. See this FAQ.

Configuration error under mailnews/intl (C-C TB): Script for generating charsetalias.properties.h does not exist ...

RESOLVED FIXED in Thunderbird 41.0

Status

Thunderbird
Build Config
--
blocker
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ISHIKAWA, Chiaki, Assigned: ISHIKAWA, Chiaki)

Tracking

unspecified
Thunderbird 41.0

Thunderbird Tracking Flags

(thunderbird41 fixed, thunderbird_esr38 unaffected)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Created attachment 8614738 [details] [diff] [review]
Fixing the configuration bustage caused by incorrect pathname.

Configuration error under mailnews/intl (C-C TB): Script for generating charsetalias.properties.h does not exist ...

I updated local C-C source tree an hour ago.

During configuration, an error occurs and
aborts the configuration process.

e.g.:
/REF-COMM-CENTRAL/comm-central/ is my MOZSRC
/REF-OBJ-DIR/objdir-tb3 is my MOZOBJ

       ...
Reticulating splines...
Traceback (most recent call last):
  File "./config.status", line 1107, in <module>
    config_status(**args)
  File "/REF-COMM-CENTRAL/comm-central/mozilla/python/mozbuild/mozbuild/config_status.py", line 149, in config_status
    summary = the_backend.consume(definitions)
  File "/REF-COMM-CENTRAL/comm-central/mozilla/python/mozbuild/mozbuild/backend/base.py", line 180, in consume
    for obj in objs:
  File "/REF-COMM-CENTRAL/comm-central/mozilla/python/mozbuild/mozbuild/frontend/emitter.py", line 159, in emit
    objs = list(self.emit_from_context(out))
  File "/REF-COMM-CENTRAL/comm-central/mozilla/python/mozbuild/mozbuild/frontend/emitter.py", line 612, in emit_from_context
    for obj in self._process_generated_files(context):
  File "/REF-COMM-CENTRAL/comm-central/mozilla/python/mozbuild/mozbuild/frontend/emitter.py", line 866, in _process_generated_files
    % (f, script), context)
mozbuild.frontend.reader.SandboxValidationError: 
==============================
ERROR PROCESSING MOZBUILD FILE
==============================

The error occurred while processing the following file or one of the files it includes:

    /REF-COMM-CENTRAL/comm-central/mailnews/intl/moz.build

The error occurred when validating the result of the execution. The reported error is:

    Script for generating charsetalias.properties.h does not exist: /REF-COMM-CENTRAL/comm-central/REF-COMM-CENTRAL/comm-central/mozilla/intl/locale/props2arrays.py


*** Fix above errors and then restart with\
               "make -f client.mk build"
/REF-COMM-CENTRAL/comm-central/client.mk:361: recipe for target 'configure' failed
make[1]: *** [configure] Error 1
make[1]: Leaving directory '/REF-COMM-CENTRAL/comm-central'
client.mk:375: recipe for target '/REF-OBJ-DIR/objdir-tb3/config.status' failed
make: *** [/REF-OBJ-DIR/objdir-tb3/config.status] Error 2


The attached patch fixed the issue, but I have no idea what is going on...

TIA


A very similar problem seems to have been attacked in
Bug 1044439
	
No rule to make target `/home/josiah/comm-central/mozilla/intl/locale/src/props2arrays.py', needed by `charsetalias.properties.h' Build regression due to bug 1038537
But in that case, the message is very different, and
so it seems some script change for build system may have
changed the behavior.
(Assignee)

Updated

2 years ago
Attachment #8614738 - Flags: review?(standard8)
(Assignee)

Updated

2 years ago
Assignee: nobody → ishikawa
Comment on attachment 8614738 [details] [diff] [review]
Fixing the configuration bustage caused by incorrect pathname.

Review of attachment 8614738 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not being too active on this reviews at the moment, unless there's a specific bit that needs my advice and someone else can't handle it.
Attachment #8614738 - Flags: review?(standard8) → review?(Pidgeot18)
Comment on attachment 8614738 [details] [diff] [review]
Fixing the configuration bustage caused by incorrect pathname.

Review of attachment 8614738 [details] [diff] [review]:
-----------------------------------------------------------------

If you value my opinion on this, it looks good to me. r=philipp
Attachment #8614738 - Flags: review?(Pidgeot18) → review+

Comment 3

2 years ago
See Bug 1170431  In that, they change like this:

-props2arrays = TOPSRCDIR + '/intl/locale/props2arrays.py'
+props2arrays = '/intl/locale/props2arrays.py'

At this point, this bug is a blocker, so I think we should just go with the existing patch and review.
Severity: normal → blocker

Comment 4

2 years ago
https://hg.mozilla.org/comm-central/rev/e0f36011323e
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-thunderbird41: --- → fixed
status-thunderbird_esr38: --- → unaffected
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 41.0
(Assignee)

Comment 5

2 years ago
(In reply to Kent James (:rkent) from comment #4)
> https://hg.mozilla.org/comm-central/rev/e0f36011323e

Ahem, thanks.

Too be honest, I have still no idea why the path got screwed up, but without it,
it does not build. Oh, well.

People can blame me when it will break again :-)
(In reply to ISHIKAWA, Chiaki from comment #5)
> (In reply to Kent James (:rkent) from comment #4)
> > https://hg.mozilla.org/comm-central/rev/e0f36011323e
> 
> Ahem, thanks.
> 
> Too be honest, I have still no idea why the path got screwed up, but without
> it,
> it does not build. Oh, well.

Likely, this is fallout of GENERATED_FILES using new moz.build path rules, so that '/' now explicitly refers to the topsrcdir of the build instead of the filesystem topsrcdir. I did mention on IRC, but apparently after the checkin, that this path should ideally have been made srcdir-absolute (i.e., drop the TOPSRCDIR +) instead of a relative path.
You need to log in before you can comment on or make changes to this bug.