Closed Bug 1171085 Opened 5 years ago Closed 5 years ago

[Control Center] Restore keyboard accessibility for identity panel

Categories

(Firefox :: General, defect, P1)

defect
Points:
5

Tracking

()

VERIFIED FIXED
Firefox 42
Iteration:
42.1 - Jul 13
Tracking Status
firefox41 + verified
firefox42 + verified

People

(Reporter: ttaubert, Assigned: ttaubert)

References

Details

(Keywords: access, Whiteboard: [fxprivacy] [campaign])

Attachments

(2 files, 2 obsolete files)

Bug 1146269 removed the autofocus but we need to bring it back in. Otherwise keyboard navigation inside the panel is mostly not possible.
Flags: qe-verify+
Flags: firefox-backlog+
Whiteboard: [fxprivacy]
Hi Team, does bug 1171085 block the release of the initial user story (bug 1168883) or can bug 1171085 be dealt with later on?
Flags: needinfo?(ttaubert)
It's not blocking the story but it should "block" the release. We shouldn't ship 41 without that fixed. It might maybe block bug 1168423? We need that to fix it.
Flags: needinfo?(ttaubert)
(In reply to Tim Taubert [:ttaubert] from comment #2)
> It's not blocking the story but it should "block" the release. We shouldn't
> ship 41 without that fixed. It might maybe block bug 1168423? We need that
> to fix it.

Sounds good.  I'll make bug 1171085 a dependency of bug 1168423.
Blocks: 1168423
Blocks: 1172919
No longer blocks: 1168423
Points: --- → 1
Duplicate of this bug: 1177703
Points: 1 → 5
Picking this up, we can't currently navigate the control panel with the keyboard and we'd need to uplift the fix to 41.
Status: NEW → ASSIGNED
Iteration: --- → 42.1 - Jul 13
Priority: -- → P1
Rank: 29
This should look decent on all platforms and makes keyboard navigation work, including showing and hiding subviews.
Attachment #8627719 - Flags: review?(gijskruitbosch+bugs)
Here's how it looks like on OS X.
Small fix for the footer button on Linux.
Attachment #8627719 - Attachment is obsolete: true
Attachment #8627719 - Flags: review?(gijskruitbosch+bugs)
Attachment #8627739 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8627739 [details] [diff] [review]
0001-Bug-1171085-Control-Center-Implement-keyboard-naviga.patch, v2

Review of attachment 8627739 [details] [diff] [review]:
-----------------------------------------------------------------

This generally looks good (though conflicts now that tp-for-control-center landed), except that if I:

1) focus the "more information" button
2) click the |>| expander

I still see a focus outline on the more information button - but hitting space/enter does nothing.

Can you fix this? :-)
Attachment #8627739 - Flags: review?(gijskruitbosch+bugs)
QA Contact: mwobensmith
Thanks for finding that scenario you describe above, it's fixed in this patch:

1) When toggling subviews an the expand button isn't the focused element, then clear the window's focus.

2) Added <menulist> elements from the permissions section to the -moz-user-focus:ignored list when showing a subview.

3) This patch removes the blur handler as it interferes with (1).


What I didn't realize when landing bug 1146269 is that the blur handler (3) took care of closing the identity panel when the focus went away so that it's closed when switching tabs, opening a new tab, closing a tab, and similar actions. With no element having a focus by default that doesn't work anymore, and I think that the current behavior of not focusing anything until the user <TAB>s around is the right behavior.

Will file a follow-up to see what we can do about closing the popup when obviously the user expects it to close, e.g. when opening a new tab or switching tabs.
Attachment #8627739 - Attachment is obsolete: true
Attachment #8629645 - Flags: review?(gijskruitbosch+bugs)
(In reply to Tim Taubert [:ttaubert] from comment #10)
> Will file a follow-up to see what we can do about closing the popup when
> obviously the user expects it to close, e.g. when opening a new tab or
> switching tabs.

Filed bug 1180642.
[Tracking Requested - why for this release]:

Need to bring back keyboard navigation for the identity panel.
Summary: [Control Center] Bring back autofocus when opening the identity panel → [Control Center] Restore keyboard accessibility for identity panel
Why can't we focus the anchor instead? Then we can keep the blur handler...
Flags: needinfo?(ttaubert)
(In reply to :Gijs Kruitbosch from comment #13)
> Why can't we focus the anchor instead? Then we can keep the blur handler...

That doesn't work unfortunately. If an element outside of the panel is focused the focus manager will not switch to any of the elements in the popup. We could fall back to focusing the "More Information" button by default but we'd have to clear its focus when showing a subview and then face the same problem again :/
Flags: needinfo?(ttaubert)
Attachment #8629645 - Flags: review?(gijskruitbosch+bugs) → review+
Depends on: 1180841
https://hg.mozilla.org/mozilla-central/rev/d4708e272a05
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Comment on attachment 8629645 [details] [diff] [review]
0001-Bug-1171085-Control-Center-Implement-keyboard-naviga.patch, v3

Approval Request Comment
[Feature/regressing bug #]: bug 1146269
[User impact if declined]: Identity panel is not keyboard accessible.
[Describe test coverage new/current, TreeHerder]: No special test coverage.
[Risks and why]: Low risk.
[String/UUID change made/needed]: None.
Attachment #8629645 - Flags: approval-mozilla-aurora?
Tracking, see Comment 2
Comment on attachment 8629645 [details] [diff] [review]
0001-Bug-1171085-Control-Center-Implement-keyboard-naviga.patch, v3

Has been on m-c for 3 days with no known issues, low-risk.
Attachment #8629645 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [fxprivacy] → [fxprivacy] [campaign]
Verified fixed FF 41b2, 42.0a2 (2015-08-20) Win 7.
Status: RESOLVED → VERIFIED
Actually I'm unable to navigate with keyboard inside the panel on OS X 10.10.5, 42.0a2 (2015-08-23), 43.0a1 (2015-08-23). Thoughts?
Works fine on Win 7, Ubuntu 14.04.
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Paul Silaghi, QA [:pauly] from comment #22)
> Actually I'm unable to navigate with keyboard inside the panel on OS X
> 10.10.5, 42.0a2 (2015-08-23), 43.0a1 (2015-08-23). Thoughts?
> Works fine on Win 7, Ubuntu 14.04.

You're testing on OS X and you haven't set the "full keyboard access" pref? (system Keyboard preferences, in the "Shortcuts" tab on yosemite)
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(paul.silaghi)
Thank you. That was the problem.
Flags: needinfo?(paul.silaghi)
Gijs, after setting "full keyboard access" on a macbook pro retina with OS X 10.9.5, I can only use "Space" to select an option and navigate further. "Enter" shouldn't have the same behavior?
  
On Win and Ubuntu "Enter" key can also be used. 

Thank you!
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Petruta Rasa [QA] [:petruta] from comment #25)
> Gijs, after setting "full keyboard access" on a macbook pro retina with OS X
> 10.9.5, I can only use "Space" to select an option and navigate further.
> "Enter" shouldn't have the same behavior?
>   
> On Win and Ubuntu "Enter" key can also be used. 
> 
> Thank you!

I think enter should work, but that is not a bug in this patch. Please file a separate unrelated bug about this and CC me, and needinfo enndeakin about this behaviour.
Flags: needinfo?(gijskruitbosch+bugs)
You need to log in before you can comment on or make changes to this bug.