Netmonitor doesn't show embedded video content

RESOLVED DUPLICATE of bug 1122832

Status

RESOLVED DUPLICATE of bug 1122832
4 years ago
8 months ago

People

(Reporter: canuckistani, Unassigned)

Tracking

41 Branch

Firefox Tracking Flags

(firefox41 affected)

Details

STR:

1. open the netmonitor, 
2. goto http://experienceperception.com/
3. click on Media - no video files are shown / filter on 'background'

Expected: should see video files being loaded

Actual: don't see any requests to these urls:

 - http://experienceperception.com/wp-content/uploads/2014/06/EP_background_v21.webm
 - http://experienceperception.com/wp-content/uploads/2014/06/EP_background_Converted.mp4
 - http://experienceperception.com/wp-content/uploads/2014/06/EP_background_v21.ogv

( aside: the one used by Firefox should be the ogg/theora file, yes? )
When I load the url in step 2, I don't see any media files listed in the netmonitor no matter what my filter is set to.  When I load the video files individually in a video document, the files get placed in the "other" category while they are loading and then, once fully loaded they will appear when filtering by media.

The video player will attempt to load the first usable file it finds.  The player on this site lists the videos in order as WebM, MP4, OGV.  So Firefox should load the WebM file and that's what is loaded when I check the video players currentSrc property.
This seems to be limited to the WebM file.  If you delete the first <source> tag that points to the WebM file and force reload the video player, then I see a request for the MP4 file.  A request is shown for the OGV file as well if you delete the <source> tags for WebM and MP4 and then force reload the video player.  Force reloading the video player with the WebM file does not show a request for the WebM file.

To see the other files load:
1) In inspector select the video element.
2) Open the console.
3) Type $0.firstElementChild.remove()
4) Type $0.load()

This will remove the offending source element containing the webm file and then force the video player to restart its load sequence with the remaining sources available.
It's a known bug. I assume some weird interaction with the cache, not sure if media files are cached differently.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1122832

Updated

8 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.