Events rescheduled by organiser are not rescheduled on my Thunderbird calendar

RESOLVED DUPLICATE of bug 1274728

Status

Calendar
Provider: GData
RESOLVED DUPLICATE of bug 1274728
3 years ago
2 years ago

People

(Reporter: quiet.dragon, Unassigned)

Tracking

Lightning 3.3

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141013200257

Steps to reproduce:

Thunderbird 31.6.0 with Provider for Google Calendar 1.0.4

Organiser creates event on Google Calendar and sends invitation
Provider syncs and I accept invitation
Organiser postpones event on Google Calendar


Actual results:

I continue to see the event I accepted on Thunderbird, even though the actual event has been postponed.


Expected results:

The postponed event should show on my Thunderbird calendar at the new time.

Updated

3 years ago
Version: unspecified → Lightning 3.3

Comment 1

3 years ago
Is this a reccurring or single event? If the former, was only one occurence moved or the entire series?
(Reporter)

Comment 2

3 years ago
The one I was referring to above is a weekly recurring event, and the event that was moved was a single occurrence within that series. The weekly recurring event is set for Tuesday at 1430 each week. One of these events was changed to Tuesday 1600, but just for that one day.

Comment 3

3 years ago
Do you have any message in the error log (ctrl+shift+j) when experiencing this? This may be related to the issue in bug 1170271.
(Reporter)

Comment 4

3 years ago
Unfortunately my desktop has been shut down for an office move. Are the logs in question persistent across a reboot ?

From reading the description of bug 1170271, it seems that there is a good chance this issue is related to that one.

Looking at the error log on my laptop (different Thunderbird instance on a different machine), I see this error arise if I force a resync:

[JavaScript Error: "[calCachedCalendar] replay action failed: null, uri=googleapi://xxxx@xxxxxx.com/?calendar=xxxx%40xxxxxx.com, result=item.recurrenceInfo is null, op=[xpconnect wrapped calIOperation]"]

I'm not sure if this is the same problem since the event in question is now in the past.

Comment 5

3 years ago
Thanks. No, the log is not persisted. This seems to be a different error message than in bug 1170271.

Can you please provide also the source file reference of the error message? Also, if you enable calendar.debug.log and calendar.debug.log.verbose in the config editor and check whether there are more related messages?
(Reporter)

Comment 7

3 years ago
Is this the information you are looking for ?

[calGoogleCalendar] Logging calIEvent:
	id:xxxxxx@google.com
	created:2015/06/04 23:57:10 UTC isDate=0 nativeTime=1433462230000000
	updated:2015/06/05 19:20:29 UTC isDate=0 nativeTime=1433532029000000
	title:xxxxx
	description:xxxx 

blah blah blah

	transparency:null
	status:CONFIRMED
	startTime:2015/06/16 10:00:00 America/Vancouver isDate=0 nativeTime=1434474000000000
	endTime:2015/06/16 10:30:00 America/Vancouver isDate=0 nativeTime=1434475800000000
	location:null
	privacy:null
	sequence:0
	alarmLastAck:null
	snoozeTime:null
	isOccurrence: false
	Organizer: 
		ID: mailto:xxxx@xxxxxx.com
			Name: XXXX
			Rsvp: null
			Is Organizer: yes
			Role: null
			Status: null
	Attendees: 

		ID: mailto:xxxx@xxxxxx.com
			Name: XXXX
			Rsvp: null
			Is Organizer: no
			Role: REQ-PARTICIPANT
			Status: ACCEPTED
...

	recurrence: no
	alarms: no

[calGoogleCalendar] Error syncing:
2147500037: (resource://gdata-provider/modules/gdataUtils.jsm:1012):TypeError: item.recurrenceInfo is null

[JavaScript Error: "[calCachedCalendar] replay action failed: null, uri=googleapi://xxxx@xxxxxx.com/?calendar=xxxx%40xxxxxx.com, result=item.recurrenceInfo is null, op=[xpconnect wrapped calIOperation]"]

Comment 8

3 years ago
Thanks. It looks to me like the parent event is not resolved correctly, but I'm not that familiar with the provider code and the Google API. Philipp, do you take a look at this?
Flags: needinfo?(philipp)

Comment 9

3 years ago
I can confirm this curiosity. It happened already the second time.
You can add new events, these are posted correct to google. But when these events are modified via mobile or google-web, it is not re-synced whithin Thunderbird.
To repaire it, remove the google subscription and re-add the calendar.
For controlling, i added two google calendar via ICS/CalDAV.

I also got this error:
Fehler: [calCachedCalendar] replay action failed: null, uri=https://www.google.com/calendar/feeds/qwertzuiop%40googlemail.com/private-123456789/basic, result=2147500037, op=[xpconnect wrapped calIOperation]
Quelldatei: file:///C:/.../thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js
Zeile: 322

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
I've gotten an email report about this before, its not clear to me which event exactly is causing this and why its happening. The only way I can figure out more is to add debug statements around gdataUtils.jsm line 1012, e.g. which event this is, what the icalString looks like, maybe what the JSON for that event looks like.

Unfortunately I haven't had time to set up an xpi for testing on this. Leaving needinfo so I can get around to it eventually.
(Reporter)

Comment 11

2 years ago
Doing some housekeeping, and stumbled across more messages similar to the previous using:

Thunderbird 38.3.0
Lightning 4.0.3
Provider for Google Calendar 1.0.4

************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: item.recurrenceInfo is null
Full stack: ItemSaver.prototype.processException@resource://gdata-provider/modules/gdataUtils.jsm:1012:13
ItemSaver.prototype.parseEventStream/<@resource://gdata-provider/modules/gdataUtils.jsm:989:27
TaskImpl_run@resource://gre/modules/Task.jsm:330:41
TaskImpl_handleResultValue@resource://gre/modules/Task.jsm:393:7
TaskImpl_run@resource://gre/modules/Task.jsm:332:11
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:867:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:746:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:688:37

*************************
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: item.recurrenceInfo is null
Full stack: ItemSaver.prototype.processException@resource://gdata-provider/modules/gdataUtils.jsm:1012:13
ItemSaver.prototype.parseEventStream/<@resource://gdata-provider/modules/gdataUtils.jsm:989:27
TaskImpl_run@resource://gre/modules/Task.jsm:330:41
TaskImpl_handleResultValue@resource://gre/modules/Task.jsm:393:7
TaskImpl_run@resource://gre/modules/Task.jsm:332:11
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:867:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:746:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:688:37

*************************
Error: [calCachedCalendar] replay action failed: null, uri=googleapi://xxxx@xxxxxxxx.com/?calendar=xxxxxxxxxx.xx_3338303433303030333331%40resource.calendar.google.com, result=item.recurrenceInfo is null, op=[xpconnect wrapped calIOperation]
*************************

Comment 12

2 years ago
I suggest that it may be similar to bug #1227414.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(philipp)
Resolution: --- → DUPLICATE
Duplicate of bug: 1274728
You need to log in before you can comment on or make changes to this bug.